Author Topic: "Jingle call failed. Incomplete caller"  (Read 735 times)

robotwin

  • Newbie
  • *
  • Posts: 4
    • View Profile
"Jingle call failed. Incomplete caller"
« on: March 08, 2017, 10:32:30 AM »
This error occurs in Yate Client after dialing with a fresh Yate install, enabled sniffing and following the guide at http://docs.yate.ro/wiki/Connecting_To_Google_Voice. Is there something else Yate must do?


marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: "Jingle call failed. Incomplete caller"
« Reply #1 on: March 09, 2017, 02:01:40 AM »
Your setup won't work.
You have a Yate server (let's name it B) which connects to Google.
You have a Yate Client who registers a sip account to B.
You are calling from A using the sip account and alter target in routing setting Google account data: wrong!

You may:
1. Connect to Google from YateClient and make your call from there
2. Call from A to B (using the sip account, don't change any data in regexroute) and route the call to Google in B

robotwin

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: "Jingle call failed. Incomplete caller"
« Reply #2 on: March 09, 2017, 08:31:04 AM »
Thanks for replying!

Apologies for my confusion, but none of the instructions I followed at http://docs.yate.ro/wiki/Connecting_To_Google_Voice are about setting Google account data during routing, and none of my logs show setting Google account data during routing.

This is the route that I used in regexroute.conf, which I cut & pasted from docs.yate.ro:
Code: [Select]
^\(+\?1[1-9][0-9]\{2\}[1-9][0-9]\{6\}\)$=jingle/\1@voice.google.com;line=GoogleVoice;\
 ojingle_version=0;ojingle_flags=noping;redirectcount=5;checkcalled=false;dtmfmethod=rfc2833

Are you advising me to remove the regex from the route? I tried replacing the regex with the explicit phone number but got the same error. Does "Jingle call failed. Incomplete caller" mean that google account data is wrong, or does it mean a parameter is missing?

Thanks again for your help.
« Last Edit: March 09, 2017, 08:39:18 AM by robotwin »

marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: "Jingle call failed. Incomplete caller"
« Reply #3 on: March 09, 2017, 08:38:04 AM »
It means you are setting the route in the wrong yate instance!
Of course you don't have a GoogleVoice account in YateClient. You have it in server.

The documentation at  http://docs.yate.ro/wiki/Connecting_To_Google_Voice explicitly states that it refers to server side config.
In YateClient you don't need to configure it. All you need to do is to create the sip account, register to server and call the number you want to. The server will route the call to google as instructed in it's regexroute.

robotwin

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: "Jingle call failed. Incomplete caller"
« Reply #4 on: March 09, 2017, 08:56:53 AM »
That makes sense and I did follow those instructions. Where in my logs does it show a GV account is configured in the Yate Client?

Here is the SIP entry in regfile.conf:
Code: [Select]
[200]
password=mysecret2

And here is the client setting screenshot:
« Last Edit: March 09, 2017, 09:06:05 AM by robotwin »

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: "Jingle call failed. Incomplete caller"
« Reply #5 on: March 09, 2017, 09:05:10 AM »
clientlog.txt shows that you are routing in client to Google. See :

Quote
Sniffed 'call.route' time=1488989110.984375
  thread=02FF4A68 'Call Router'
  data=00000000
  retval='(null)'
  param['id'] = 'client/4'
  param['module'] = 'client'
  param['status'] = 'incoming'
  param['billid'] = '1488988375-4'
  param['answered'] = 'false'
  param['direction'] = 'incoming'
  param['called'] = '18005551212'
  param['line'] = 'sip:200@192.168.0.9'
  param['account'] = 'sip:200@192.168.0.9'
Returned true 'call.route' delay=0.000000
  thread=02FF4A68 'Call Router'
  data=00000000
  retval='jingle/18005551212@voice.google.com'
  param['id'] = 'client/4'
  param['module'] = 'client'
  param['status'] = 'incoming'
  param['billid'] = '1488988375-4'
  param['answered'] = 'false'
  param['direction'] = 'incoming'
  param['called'] = '18005551212'
  param['line'] = 'GoogleVoice'
  param['account'] = 'sip:200@192.168.0.9'
  param['handlers'] = 'javascript:15,cdrbuild:50,fileinfo:


So you either modified the configuration for the client. Or the client and server read configuration from the same place.
If you have installed both Yate and YateClient on the same machine, please start one with a different configuration directory. The default one is /etc/yate. Please check the '-c' command line option.


robotwin

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: "Jingle call failed. Incomplete caller"
« Reply #6 on: March 09, 2017, 09:31:24 AM »
Aha! Thank you for helping me understand that the client and server use the same configuration files if they are in the same directory. That fact was not clearly in the how-to guide. It's easy to make this mistake because the windows installer puts everything in the same directory by default.

It works correctly now that I changed that. Thank you all again.
« Last Edit: March 09, 2017, 09:37:49 AM by robotwin »