Author Topic: Problem : Registration fail  (Read 284 times)

K.

  • Newbie
  • *
  • Posts: 11
    • View Profile
Problem : Registration fail
« on: July 21, 2017, 06:39:48 AM »
Hello,

After I have DTMF problem, I decided to reinstall yate and yatebts to the newest version from SVN. I have successfully installed yate and yatebts. The problem is I couldn't connect my cell phone to the bts. The phone can see the network but somehow could not register to the network.

Can anyone give me any idea  :)
I have attached the log file with this post.



marian

  • Sr. Member
  • ****
  • Posts: 384
    • View Profile
Re: Problem : Registration fail
« Reply #1 on: July 24, 2017, 12:59:24 AM »
Please update board's firmware to 1.8.0:
See: https://wiki.yatebts.com/index.php/Write_new_firmware_to_bladeRF

Please use fpga files distributed with yate (version 0.1.2): other versions were not tested

K.

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Problem : Registration fail
« Reply #2 on: July 25, 2017, 02:29:27 AM »
Hey marian,

I already updated the firmware version to 1.8.0. My cell phone can connect the to the bts and can make a call. Thank you !

K.

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Problem : Registration fail
« Reply #3 on: July 25, 2017, 08:01:21 AM »
Hey marian,

I still have some problem and questions about the yatebts.

1) Even though, I can make a call between two cell phones but I still cannot send any sms at all.
2) From the topic (http://forum.yate.ro/index.php?topic=1443.msg5388#msg5388). I still don't understand how can I record a wavefile. Some more explanation would help.  :)

Best Regards,
Khem

marian

  • Sr. Member
  • ****
  • Posts: 384
    • View Profile
Re: Problem : Registration fail
« Reply #4 on: July 26, 2017, 12:51:55 AM »
For SMS: a log with message sniffer enabled would help to see what happens.

For call record: please tell what is it that you don't understand.

K.

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Problem : Registration fail
« Reply #5 on: July 26, 2017, 01:59:28 PM »
Hello marian,

For the sms problem, I just found that the sms doesn't work only with my own written sim card. The sms worked fine with other sim card. I guess the problem is I didn't write that sim card correctly.

For the call record, after reading the yate documents and old topics, I did some configuration in regexroute.conf. I did record the wave file in .au file. But it seem like the quality was very bad, I could barely hear the voice. Any idea on how to fix this issue?

Regards,
Khem   

marian

  • Sr. Member
  • ****
  • Posts: 384
    • View Profile
Re: Problem : Registration fail
« Reply #6 on: July 28, 2017, 12:46:27 AM »
Try a different format (slin).
Check if received data (audio) is good: record is as good as received audio data!

K.

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Problem : Registration fail
« Reply #7 on: July 28, 2017, 01:16:24 AM »
Hello marian,

Thank you for your suggestion. My record file is looking good right now!  ;)

Regards,
Khem