Author Topic: YateBTS with LimeSDR problem  (Read 246 times)

Xhizors

  • Newbie
  • *
  • Posts: 1
    • View Profile
YateBTS with LimeSDR problem
« on: August 11, 2017, 05:41:28 PM »
Hello Yate community ! I'm trying to run run the Yate and YateBTS on LimeSDR, however when I start yate -v this is the error:

Code: [Select]
[b]Release 5.0.1 formal build date Aug 11 2017 rev646
2017-08-12_02:33:23.041348 <mbts:NOTE> GSMConfig.cpp:80:regenerateBeacon: regenerating system information messages, changemark 1
Starting MBTS...
2017-08-12_02:33:23.041708 <ybts:NOTE> State changed WaitHandshake -> Running
2017-08-12_02:33:23.041784 <gsmtrx:CRIT> Failed to create radio interface: Message not handled
ALERT 140215268927296 02:33:23.0 TRXManager.cpp:210:sendCommand: RESET failed with status 2
2017-08-12_02:33:23.041886 <mbts:WARN> TRXManager.cpp:210:sendCommand: RESET failed with status 2
ALERT 140215268927296 02:33:23.0 OpenBTS.cpp:251:main: Failed to reset transceiver
2017-08-12_02:33:23.041953 <mbts:WARN> OpenBTS.cpp:251:main: Failed to reset transceiver
2017-08-12_02:33:23.058880 <NOTE> Failed to open config file '/usr/local/etc/yate/tmsidata.conf', using defaults (2: No such file or directory)
Yate engine is initialized and starting up on ThinkPad-T560
2017-08-12_02:33:23.970147 <cpuload:NOTE> Updating CPU core number from 1 to 4
2017-08-12_02:33:27.003425 <ybts:NOTE> Peer pid 4223 vanished
2017-08-12_02:33:28.002382 <ybts:NOTE> 'shutdown' command failed
2017-08-12_02:33:28.023090 <ybts:NOTE> State changed Running -> Idle
2017-08-12_02:33:29.001519 <ybts:NOTE> State changed Idle -> Starting restart counter 2/10
[/b]
Drivers and everything works fine, tried to change the transceiver path to all available options(./transceiver , ./ tranceiver-usrp and so on ) without any luck.
Any tips are welcome, as I'm in the beginning of exploring my LimeSDR.
Thank you !

marian

  • Sr. Member
  • ****
  • Posts: 382
    • View Profile
Re: YateBTS with LimeSDR problem
« Reply #1 on: August 14, 2017, 12:39:39 AM »
bladeRF (radio) module is not available: not built or not installed.
If you are building yate: bladerf module depends on libusb. Make sure libusb devel package is installed.

K.

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: YateBTS with LimeSDR problem
« Reply #2 on: August 14, 2017, 02:09:35 AM »
Hi,

I think you need to install libusb library, then try reinstalling Yate.

sudo apt-get install libusb-1.0.0-dev     << to install libusb

Then run ./configure and make, make install Yate again.
Hope this help.

Khem