Author Topic: Using Yate with Cisco's Callgen  (Read 1949 times)

monks

  • Newbie
  • *
  • Posts: 1
    • View Profile
Using Yate with Cisco's Callgen
« on: May 16, 2013, 02:28:06 AM »
Hi All Community members,
This is my first Post on Yate forums and im very new to this Technology as well. But i've fairly good xperience working on Open Source on Linux.
Recently requirement came to us to use Cisco's Callgen module with Yate. For those who r unaware of callgen, its used as a Load testing tool by pumping calls to CVP.  load testing should tell us how many ports are working and how many failed, etc...

So till date, im able to Deploy and configure Yate on Ubuntu. I can see Callgen.Yate within Yate's Modules directory.
Also, if i run and execute Yate using ./run, it shows me messg - Yate Engine is Initialized and starting up on VM
So by above, it seems to me that Yate is being properly configured and Callgen module is there.
Now , my next step is to use Callgen Module & its functionality within Yate for Call Load testing.

My first question is ,
1) why im getting below error when running Yate instance like : ./yate
    Error :- error while loading shared libraries: libyate.so.4.3..0: cannot open shared file: No such file

2) How can i proceed further to test Callgen with Yate ?
    Does anyone having experience using same concept ( Yate+Callgen) before. I would appreciate for any pointers regarding same as im new to bot yate & callgen.

Thanks,
Mayank





Diana Cionoiu

  • Administrator
  • Jr. Member
  • *****
  • Posts: 71
    • View Profile
Re: Using Yate with Cisco's Callgen
« Reply #1 on: May 17, 2013, 04:13:25 PM »
1. the libyate.so.4.3 is not in the library path, if you use yate from source code use ./run

2. http://yate.ro/pmwiki/index.php?n=Main.Callgen