Author Topic: Can't find or build yate client in debian 9  (Read 70 times)

eble

  • Newbie
  • *
  • Posts: 2
    • View Profile
Can't find or build yate client in debian 9
« on: August 24, 2017, 06:56:18 AM »
Hello all,

I just happened to compile yate under Debian 9. But I can't find the Client. There is no YateClient nor is there a qt4client. I do have a clients subdirectory in the sources. But nothing happens when I type make, "Nothing to make for target all". If I ./run-qt4 then "Could not find Client executable or run script. So the question is: How can I start/find/build the Client?
Version of yate:
Yate 5.5.0 1 r6255
All of the documentation seems to refer either to the Server or the *Windows* Client. Any help is appreciated. Best regards Johannes

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Can't find or build yate client in debian 9
« Reply #1 on: August 25, 2017, 06:28:12 AM »
Please post a log of configure and build steps.

eble

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Can't find or build yate client in debian 9
« Reply #2 on: September 11, 2017, 11:17:02 AM »
Hello Ioana,

thanks for your reply, and apologize my delay. Unfortunately, I have completely broken my Debian VM, so I had to install everything again. Now, trying to build yate again, I have cloned this site: https://github.com/vir/yate/. I tried to follow the build steps, but ./configure failed since there is no such file. There is merely a configure.ac. So, how do I build it instead?
Best regards
Johannes

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Can't find or build yate client in debian 9
« Reply #3 on: September 12, 2017, 02:12:03 AM »
If you are building from sources, you first need to run './autogen.sh' in order to generate configure from configure.ac.