Author Topic: yate won't start  (Read 9158 times)

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
yate won't start
« on: December 30, 2013, 12:19:49 PM »
I am using yate 4.3.0-i586-3vl70.  After updating firefox, I now get the following error ("..." means that lines have been omitted):

Quote

Yate (9184) is starting Mon Dec 30 10:09:58 2013
...
<RManager:GOON> Failed to bind to 127.0.0.1:5038 : Address already in use
...
<mgcp_gw:WARN> Failed to bind socket to :2427. Error: 98: Address already in use
Initializing module SNMP Agent
<WARN> Failed to save config file '/etc/yate/snmp_data.conf' (13: Permission denied)
<snmpagent:WARN> Could not bind SNMP UDP Listener, error 13 Permission denied
...
Initialization complete
Yate engine is initialized and starting up on vector.linux.net
^CYate engine is shutting down with code 0
<WARN> Failed to save config file '/etc/yate/snmp_data.conf' (13: Permission denied)
Suggestions?  I am reading the instructions but first couple of things I tried didn't help.
« Last Edit: December 30, 2013, 03:49:36 PM by Lawquest »

marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #1 on: January 06, 2014, 03:14:34 AM »
Hi,

Check if you have another yate instance running (command: pidof yate).

Check listening ports with netstat:
netstat -l
If you have root access you can see the processes also:
netstat -lp

Try telnet 127.0.0.1 5038. See if it succeeds

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #2 on: January 08, 2014, 03:22:17 AM »
Thanks marian!

I have been fooling around a lot lately with yate, trying to get it to work without success.  I now get a different error, as follows:

Quote
<snmpagent:WARN> Could not bind SNMP UDP Listener, error 13 Permission denied

Now the results of my following your kind suggestions:

Before attempting to start yate at the terminal:

     pidof yate shows nothing.

    netstat -l shows a lot of stuff, but does not show yate anywhere, nor does netstat -lp as root.  Netstat -l did show yate at the time I originally posted (when yate showed the port 2427 error). 

   I do not know how to try " telnet 127.0.0.1 5038"

I would be happy to post the results of netstat -l and netstat-lp if you think that might help.

John



   



marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #3 on: January 09, 2014, 01:34:24 AM »
The error indicates you don't have permission to open the SNMP port (default: 161).

If you need SNMP you should run yate as root or use a different port (greater then 1000).


Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #4 on: January 09, 2014, 10:47:01 AM »
Thanks Marian,

I don't get the error when running yate as root, but yate gui still doesn't come up.  Here is netstat -l after running yate as root.  I note something on port 2427 and I think that is the problem but I am not familiar with this "port" business:

Quote
vector://home/johwhi
root:# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State     
tcp        0      0 localhost:5038          *:*                     LISTEN     
tcp        0      0 localhost:ipp           *:*                     LISTEN     
udp        0      0 *:sip                   *:*                                 
udp        0      0 *:4569                  *:*                                 
udp        0      0 *:35291                 *:*                                 
udp        0      0 *:ipp                   *:*                                 
udp        0      0 *:snmp                  *:*                                 
udp        0      0 *:mdns                  *:*                                 
udp        0      0 *:2427                  *:*                                 
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node Path
unix  2      [ ACC ]     SEQPACKET  LISTENING     8215   /run/udev/control
unix  2      [ ACC ]     STREAM     LISTENING     5341021 /home/johwhi/.dropbox/command_socket
unix  2      [ ACC ]     STREAM     LISTENING     5338713 /home/johwhi/.dropbox/iface_socket
unix  2      [ ACC ]     STREAM     LISTENING     5340579 /tmp/.org.chromium.Chromium.mZesga/SingletonSocket
unix  2      [ ACC ]     STREAM     LISTENING     5366005 /tmp/ksocket-johwhi/kdeinit4__0
unix  2      [ ACC ]     STREAM     LISTENING     5367971 /tmp/ksocket-johwhi/klauncherSLh361.slave-socket
unix  2      [ ACC ]     STREAM     LISTENING     5404531 /tmp/lyx_tmpdir.TJ8245/lyxsocket
unix  2      [ ACC ]     STREAM     LISTENING     5653359 /tmp/ksocket-johwhi/kdesud_:0
unix  2      [ ACC ]     STREAM     LISTENING     5402153 /tmp/orbit-johwhi/linc-1dd2-0-273e91773a9af
unix  2      [ ACC ]     STREAM     LISTENING     5365998 /tmp/orbit-johwhi/linc-162-0-6303b6624c166
unix  2      [ ACC ]     STREAM     LISTENING     5339670 /tmp/orbit-johwhi/linc-7193-0-343679a332ae6
unix  2      [ ACC ]     STREAM     LISTENING     5340434 /tmp/orbit-johwhi/linc-7181-0-2466363937810
unix  2      [ ACC ]     STREAM     LISTENING     5407219 /tmp/orbit-johwhi/linc-2035-0-159da6cf3cd7c
unix  2      [ ACC ]     STREAM     LISTENING     5339776 /tmp/.esd-1000/socket
unix  2      [ ACC ]     STREAM     LISTENING     5339778 /home/johwhi/.pulse/4af9189477700cbbfdde3f7900000019-runtime/native
unix  2      [ ACC ]     STREAM     LISTENING     5338667 /tmp/orbit-johwhi/linc-71c2-0-7474efc6a25fc
unix  2      [ ACC ]     STREAM     LISTENING     9132   /var/run/cups/cups.sock
unix  2      [ ACC ]     STREAM     LISTENING     8880   /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     5338360 @/tmp/.X11-unix/X0
unix  2      [ ACC ]     STREAM     LISTENING     19993  @/tmp/fam-johwhi-
unix  2      [ ACC ]     STREAM     LISTENING     5340287 /tmp/gpg-QpAhN3/S.gpg-agent
unix  2      [ ACC ]     STREAM     LISTENING     5340288 /tmp/gpg-86KCqX/S.gpg-agent.ssh
unix  2      [ ACC ]     STREAM     LISTENING     5341185 @/tmp/dbus-xeDwnaEVjg
unix  2      [ ACC ]     STREAM     LISTENING     5340285 /tmp/.ICE-unix/29026
unix  2      [ ACC ]     STREAM     LISTENING     6586   @/var/run/hald/dbus-gFCmFCQWoo
unix  2      [ ACC ]     STREAM     LISTENING     5402158 /tmp/qtsingleapp-Golden-86bf-3e8
unix  2      [ ACC ]     STREAM     LISTENING     5338361 /tmp/.X11-unix/X0
unix  2      [ ACC ]     STREAM     LISTENING     7528   @/var/run/hald/dbus-vORtCwA0Ob
unix  2      [ ACC ]     STREAM     LISTENING     5340284 @/tmp/.ICE-unix/29026
unix  2      [ ACC ]     STREAM     LISTENING     9254   /var/run/gdm_socket
unix  2      [ ACC ]     STREAM     LISTENING     6891   /var/run/avahi-daemon/socket
unix  2      [ ACC ]     STREAM     LISTENING     8729   /var/run/acpid.socket
unix  2      [ ACC ]     STREAM     LISTENING     5339781 /home/johwhi/.pulse/4af9189477700cbbfdde3f7900000019-runtime/dbus-socket
unix  2      [ ACC ]     STREAM     LISTENING     5340958 /tmp/orbit-johwhi/linc-718e-0-35295f5d1c79b
unix  2      [ ACC ]     STREAM     LISTENING     5367980 /tmp/orbit-johwhi/linc-16b-0-1735b01896b8a
unix  2      [ ACC ]     STREAM     LISTENING     8994   /var/run/acpid.socket
unix  2      [ ACC ]     STREAM     LISTENING     5367059 /tmp/orbit-johwhi/linc-171-0-15eb7bef417f
unix  2      [ ACC ]     STREAM     LISTENING     5372216 /tmp/orbit-johwhi/linc-5ba-0-18315587208b
unix  2      [ ACC ]     STREAM     LISTENING     5404306 /tmp/orbit-johwhi/linc-1fda-0-144492c446a2b
vector://home/johwhi

marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #5 on: January 10, 2014, 01:43:33 AM »
Hi,

You should state your issue from start.
If you want to use yate client the application to start is yate-qt4, not yate (the command 'yate' starts the server).

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #6 on: January 11, 2014, 03:36:22 PM »
thanks. that gives a segmentation fault


Quote
vector:/~
johwhi:$ yate-qt4
Segmentation fault
vector:/~
johwhi:$ su
Password:
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
vector://home/johwhi
root:# yate-qt4
Segmentation fault
vector://home/johwhi

marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #7 on: January 13, 2014, 02:13:08 AM »
Can you post a log?

yate-qt4 -vvvvv -lt yate.log

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #8 on: January 13, 2014, 10:18:01 AM »
Quote
vector:/~
johwhi:$ yate-qt4 -vvvvv -lt yate.log
Segmentation fault
vector:/~

Here is what I get when just typing yate:

Quote
vector:/~
johwhi:$ yate
Yate (2282) is starting Mon Jan 13 08:10:18 2014
Loaded module MsgSniffer
Loaded module Javascript
Loaded module RManager
Loaded module ExtModule
Loaded module DumbChannel
Loaded module CdrFile
Loaded module Analyzer
Loaded module ToneGen
Loaded module CdrBuild
Loaded module Conference
Loaded module MUX
Loaded module OpenSSL - based on OpenSSL 1.0.0d 8 Feb 2011
Loaded module Call Forker
Loaded module ZLib - using zlib library version 1.2.5
Loaded module PBX
Loaded module GVoice
Loaded module ToneDetector
Loaded module Speex - based on libspeex-1.1.16
Loaded module iLBC - based on iLBC reference library
Loaded module iSAC floating point - based on WebRTC iSAC library version 4.3.0 (SPL version 1.2.0)
Loaded module YIAX
Loaded module YJingle
Loaded module SIP Channel
Loaded module MOH
Loaded module YSOCKS
Loaded module YSTUN
Loaded module YRTP
Loaded module Call Generator
Loaded module File Transfer
Loaded module GSM - based on libgsm-1.0.10
Loaded module iLBC - based on WebRTC iLBC library version 1.1.1
Loaded module RegexRoute
Loaded module WaveFile
Loaded module CallCounters
Loaded module DbWave
Loaded module Heartbeat
Loaded module PostgreSQL
Loaded module Signalling Channel
Loaded module Monitoring
Loaded module MRCP
Loaded module Cisco SM
Loaded module Queues Notify
Loaded module Clustering
Loaded module Event Logs
Loaded module MGCP-GW
Loaded module SNMP Agent
Loaded module Register for database
Loaded module Call Parking
Loaded module Cache
Loaded module Presence
Loaded module Radius client
Loaded module Late Router
Loaded module SIP Features
Loaded module Registration from file
Loaded module CCongestion
Loaded module MGCP-CA
Loaded module Accounts from file
Loaded module SigTransport
Loaded module Queues
Loaded module Subscriptions
Loaded module Cpu
Loaded module Users Management
Loaded module Analog Detector
Loaded module MySQL based on 5.5.25
Loaded module Analog Channel
Loaded module PBX for database
Loaded module Jabber Server
Loaded module Jabber Server Features
Initializing plugins
Initializing module Jabber Server Features
Initializing module Jabber Server
Initializing module MySQL
Initializing module Analog Detector
Initializing module Cpu
Initializing module Subscriptions
Initializing module SigTransport
Initializing module MGCP Call Agent
Initializing module Event Logs
Initializing module Clustering
Initializing module Cisco SM
Initializing module PostgreSQL
Initializing module DbWave
Initializing module YSOCKS
Initializing module ZLib
Initializing module OpenSSL
Initializing module MUX
Initializing module CdrFile
Initializing module Javascript
Initializing module MsgSniffer
Initializing module RManager
<RManager:GOON> Failed to bind to 127.0.0.1:5038 : Address already in use
Initializing module ExtModule
Initializing module DumbChannel
DumbChannel initialized
Initializing module Analyzer
Initializing module ToneGen
Initializing module CdrBuild
Initializing module Conference
Initializing module Call Forker
Initializing module PBX
Initializing module GVoice
Initializing module ToneDetector
Initializing module iSAC
Initializing module YIAX
<iaxengine:WARN> Failed to bind socket on '0.0.0.0:4569' - trying a random port. 98: 'Address already in use'
Initializing module YJingle
Initializing module SIP Channel
Initializing module MOH
<sip:WARN> Listener(UDP,'general') unable to bind on '0.0.0.0:5060' - trying a random port. 98 'Address already in use'
Initializing module YSTUN
Initializing module YRTP
Initializing module Call Generator
Initializing module File Transfer
Initializing module iLBC webrtc
Initializing module RegexRoute
Initializing module WaveFile
Initializing module Signalling Channel
Initializing module Monitoring
Initializing module MrcpSpeech
Initializing module Queues Notify
Initializing module MGCP Gateway
<mgcp_gw:WARN> Failed to bind socket to :2427. Error: 98: Address already in use
Initializing module SNMP Agent
<snmpagent:WARN> Could not bind SNMP UDP Listener, error 13 Permission denied
Initializing module Register for database
Initializing module Call Parking
Initializing module Cache
Initializing module Presence
Initializing module Radius client
Initializing module Late Router
Initializing module SIP Features
Initializing module Register from file
Initializing module CCongestion
Initializing module Accounts from file
Initializing module Queues for database
Initializing module Users Management
Initializing module Analog Channel
Initializing module PBX for database
Initialization complete
Yate engine is initialized and starting up on vector.linux.net


marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #9 on: January 14, 2014, 01:47:08 AM »
The -lt command line options created the log file named yate.log.
Can we see it?

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #10 on: January 14, 2014, 05:57:23 PM »
here it is.  Or I probably should say, here I hope it is.


marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #11 on: January 15, 2014, 01:49:55 AM »
This is a log of yate server not yate-qt4.

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #12 on: January 15, 2014, 09:40:42 AM »
I can't create the requested log file:

Quote
vector:/~
johwhi:$ locate yate-qt4
/etc/yate/yate-qt4.conf
/usr/bin/yate-qt4
/usr/share/applications/yate-qt4.desktop
/usr/lib/menu/yate-qt4.menu
vector:/~
johwhi:$ cd /usr/bin yate-qt4
vector://usr/bin
johwhi:$ yate-qt4
Segmentation fault
vector://usr/bin
johwhi:$ -lt
bash: -lt: command not found
vector://usr/bin
johwhi:$ su
Password:
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
vector://usr/bin
root:# -lt
bash: -lt: command not found
vector://usr/bin
root:# yate-qt4 -vvvvv -lt yate.log
Segmentation fault
vector://usr/bin
root:# yate-qt4 -lt yate.log
Segmentation fault
vector://usr/bin

marian

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
Re: yate won't start
« Reply #13 on: January 16, 2014, 01:52:57 AM »
Try to create file in a known location, like /home/myuser/yate-qt4.log:

Command:
yate-qt4 -vvvvv -tl /home/myuser/yate-qt4.log

Lawquest

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: yate won't start
« Reply #14 on: January 16, 2014, 09:29:21 AM »
Still get segmentation fault

Quote
vector:/~
johwhi:$ yate-qt4 -vvvvv -tl /home/johwhi/yate-qt4.log
Segmentation fault
vector:/~