Author Topic: [SOLVED]the client cannot make sound in centos  (Read 4559 times)

mingg

  • Newbie
  • *
  • Posts: 8
    • View Profile
[SOLVED]the client cannot make sound in centos
« on: March 19, 2014, 04:43:26 AM »
I build and install yate5 from source code(http://voip.null.ro/tarballs/yate5/yate-5.2.0-1.tar.gz)
when i run "./run-qt4", after all modules are loaded, i get a warning showed in the terminal:"<client:WARN> QT sounds are not available"
and when a call is comming or i make a call, the gui shows:
"audio failure
Failed to open audio.
Please check your sound card"

i use wireshark to capture the packets, it shows that:
1: i can get all the sip messages correctly
2:i can receive all the rtp packets from anther yate-client(running in windows)
but, my yate-client doesn't send out any rtp-packets!! And although i can receive all rtp packets from another client, i can hear anything through my earphone.

and i also test my earphone and microphone, they work fine.

i have this method:uncheck "setting->options->telephony->Ringer", it doesn't work.

I've uploaded the log.

I hope i've made the problem clear....
« Last Edit: March 24, 2014, 09:51:52 PM by mingg »

marian

  • Sr. Member
  • ****
  • Posts: 385
    • View Profile
Re: the client cannot make sound in centos
« Reply #1 on: March 20, 2014, 02:10:28 AM »
The alsa module wasn't built or is not loaded.
The default sound module is alsachan.
Install alsa devel package, run configure again and re-build yate.

You can use the osschan module. Change yate-qt4.conf:

[client]
device=oss//dev/dsp

mingg

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: the client cannot make sound in centos
« Reply #2 on: March 20, 2014, 08:58:53 PM »
Thanks for your reply,i will try it! :)

mingg

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: the client cannot make sound in centos
« Reply #3 on: March 23, 2014, 09:04:58 PM »
The alsa module wasn't built or is not loaded.
The default sound module is alsachan.
Install alsa devel package, run configure again and re-build yate.

You can use the osschan module. Change yate-qt4.conf:

[client]
device=oss//dev/dsp

I install the alsa module, rum configure again, re-build yate and install it again.
It works, my client can send out rtp/rtcp packets, but i still cannot hear anything and the other client still cannot hear what I say(he just hears some stable noise)......
when i'm making a phone call , the terminal warns that:
"<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred
<WARN> ALSA short write, writei wrote 138 frames
<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred
<WARN> ALSA write underrun occurred"

and the QSound warning still exists:"<client:WARN> QT sounds are not available"

and I've uploaded the new log
do you have any idea about it, marian?
« Last Edit: March 23, 2014, 10:10:16 PM by mingg »

marian

  • Sr. Member
  • ****
  • Posts: 385
    • View Profile
Re: the client cannot make sound in centos
« Reply #4 on: March 24, 2014, 02:08:39 AM »
Try calling locally the tonegen module: type tone/ring in call destination area and press 'Call'. You should hear a ring tone.
If you have a server between you and the party you are talking to try calling it directly.
Try using oss (most probably won't help, but try it anyway)

For the next log(s) please start yate with -Dt to see the time a message is logged.

And forget about the QT sounds not available warning, it has nothing to do with call media.

mingg

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: the client cannot make sound in centos
« Reply #5 on: March 24, 2014, 09:51:32 PM »
Try calling locally the tonegen module: type tone/ring in call destination area and press 'Call'. You should hear a ring tone.
If you have a server between you and the party you are talking to try calling it directly.
Try using oss (most probably won't help, but try it anyway)

For the next log(s) please start yate with -Dt to see the time a message is logged.

And forget about the QT sounds not available warning, it has nothing to do with call media.

marian,thank you very much!!!!Now my yate client works perfectly!
Here is my installing steps, I hope i can help someone encounters the same problem.
I'm using ubuntu 12.04(i just point out the 2 most important dependencies: libqt4-dev and libasound2-dev, the other dependencies(for example g++, autoconf) should be installed according to the warning or error duaring your installing)
1:download the sourcecode(http://voip.null.ro/tarballs/yate5/yate-5.2.0-1.tar.gz)
2: tar -zxv -f yate-5.2.0-1.tar.gz
3: sudo apt-get install libqt4-dev #important
4: sudo apt-get install libasound2-dev #the most important step, if you are not using ubuntu(maybe centos), you can use yum search, or google(keyword: centos install alsa headers)
5: cd yate
6: ./autogen
7: make
8: sudo make install

how to start client:
9: cd client
10: sudo ./run-qt4
11: stop the ringer(setting->options->telephony, and uncheck the "Ringer")
« Last Edit: March 24, 2014, 10:00:37 PM by mingg »