Author Topic: starting up yate  (Read 2491 times)

zane93

  • Newbie
  • *
  • Posts: 8
    • View Profile
starting up yate
« on: August 19, 2014, 09:02:41 PM »
Running ubuntu 14.04. I went through the install wiki and everything installed as expected no issues. Im now trying to start yate getting this error:

$ sudo yate -sd -vvvvv -l /var/log/yate.log
yate: error while loading shared libraries: libyate.so.5.4.1: cannot open shared object file: No such file or directory

Any ideas on how to fix this? Thanks!

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: starting up yate
« Reply #1 on: August 20, 2014, 05:57:25 AM »

The path where you installed libyate is not in the path of the dynamic loader.  In order to add that path you need to edit /etc/ld.so.conf file and add a new line with the desired path. The path where you have installed libyate is probably  /usr/local/lib or /usr/local/lib64.

After you do the editing run (also as root) the following command ldconfig and then retest if you can run yate.

zane93

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: starting up yate
« Reply #2 on: August 20, 2014, 01:24:50 PM »

The path where you installed libyate is not in the path of the dynamic loader.  In order to add that path you need to edit /etc/ld.so.conf file and add a new line with the desired path. The path where you have installed libyate is probably  /usr/local/lib or /usr/local/lib64.

After you do the editing run (also as root) the following command ldconfig and then retest if you can run yate.

Many thanks it worked.
I added the below to /etc/ld.so.conf and reset with ldconfig as suggested.
include /usr/local/lib/