Poll

What operating system is best used for implementation yatebts?

Ubuntu 14.04
2 (100%)
Ubuntu 13.10
0 (0%)
Ubuntu 12.04
0 (0%)
Windows
0 (0%)

Total Members Voted: 2

Voting closed: February 28, 2015, 06:13:41 AM

Author Topic: [ASK] YateBTS Project  (Read 1839 times)

nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
[ASK] YateBTS Project
« on: January 29, 2015, 06:13:41 AM »
What operating system is best used for implementation yatebts?
And for hardware and software, what i need?

In yatebts website (yatebts.com) , i am very confused with explanation, I have not found an explanation or tutorial that I can understand.

I have a final project for my graduation requirements, And my project is " IMPLEMENTATION OF SHORT MESSAGE SERVICE ON THE GSM NETWORK USING YATE BTS".  i hope this forum can help me, thank's before

Monica Tepelus

  • Administrator
  • Full Member
  • *****
  • Posts: 162
    • View Profile
Re: [ASK] YateBTS Project
« Reply #1 on: January 29, 2015, 09:50:04 AM »
Hi,

The YateBTS Labkits use Mageia 4 but other distributions should also be ok. Also, DON'T use it in a virtual machine.
A normal computer should be ok. Yate doesn't use many resources and when it needs more memory/processing power it's because it's under heavy load.

As a starting point for your project see the NIB application. Users can send SMSs between then and user can also have SMS s conversion with elizachat bot.
 
http://wiki.yatebts.com/index.php/Javascript_NIB


nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: [ASK] YateBTS Project
« Reply #2 on: January 30, 2015, 09:38:55 AM »
Hi Monica..

can i using ubuntu 14:04? for the first step, i must install NIB?

do i have to install YAteBTS, asterisk, Smsqueue ? When?

What should I install after NIB application?

(Sorry for my bad english)

Monica Tepelus

  • Administrator
  • Full Member
  • *****
  • Posts: 162
    • View Profile
Re: [ASK] YateBTS Project
« Reply #3 on: February 02, 2015, 09:46:08 AM »
You should start by reading" The Installing and Administration" section and some of the topics from Configuration section from:
http://wiki.yatebts.com

We have installed YateBTS on Ubuntu, so I don't see an issue with that.

nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: [ASK] YateBTS Project
« Reply #4 on: February 24, 2015, 08:33:46 PM »
hi monica. I only have USRP, without having BladeRF, can I implement yatebts?