Author Topic: Setting CalledPartyNumber.nature in ISUP  (Read 978 times)

dj_ndc

  • Newbie
  • *
  • Posts: 28
    • View Profile
Setting CalledPartyNumber.nature in ISUP
« on: September 09, 2015, 01:42:49 AM »
Hello

I'am using Sangoma A104. First port is with SS7 and ISUP, 2nd, 3rd, 4th are configured as DSS1.
When I try to send call from DSS to SS7, and try to set CalledPartyNumber.nature and CallingPartyNumber.nature to international. It doesn't work. Nature is always set by Incomming ISDN setup "Calling Party Number".
I am only able to change this Value for SIP calls comming to SS7, here is my route:

.*=sig/${called}.;link=isup1;sig.CalledPartyNumber.nature=international;sig.CallingPartyNumber.screened=network-provided;sig.CallingPartyNumber.nature=international

I works only for SIP calls, when I try to send CALL from ISDN from 4th port, nature is always set by Incomming Setup from that port. Is there a way to force overwrite this Variable ?

dj_ndc

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Setting CalledPartyNumber.nature in ISUP
« Reply #1 on: September 09, 2015, 06:26:53 AM »
Hello

OK, I have handeled it by, I didn't know that DSS1 has this kind of parameters:

sig.callernumtype=international;
sig.callerscreening=network-provided;
sig.callednumtype=international;
sig.callednumplan=international

so finally I have:


sig.CalledPartyNumber.nature=international;
sig.CallingPartyNumber.screened=network-provided;
sig.TransmissionMediumRequirement=3.1khz-audio;
sig.callerscreening=network-provided;
sig.ForwardCallIndicators=international,isdn-orig,isup-path;
sig.CallingPartyNumber.nature=international;
sig.callernumtype=international;
sig.callerscreening=network-provided;
sig.callednumtype=international;
sig.callednumplan=international

Greetings