Yate Community Forum

Yate server => Other Yate server issues => Topic started by: ktrofimov on April 30, 2016, 02:34:37 PM

Title: RTP is silenced every second
Post by: ktrofimov on April 30, 2016, 02:34:37 PM
Can somebody help me? I set up a Yate with SIP trunk. I can register with privider and get an incoming calls from both outside and inside of the LAN.
Calling from mobile phone through IP using CSipSimple or Zoiper gives almost clear sound no matter where do I call from. Calls from both local WiFi or a mobile 3G network are working fine.
But calls from PSTN landline through providers gateway are terrible - 99 calls of 100 are impossible to get recognizable sound. It mutes or pauses every second. It sound like "I - ut - es - ry - nd"
Provider says it is necessary to set up a ptime=20. I disabled ilbc30=no, enabled ilbc20=yes, but it does not have any effect. ptime field did not appeated in SDP "OK" packet. Finally I hardcoded ptime=20 in SDP's session.cpp but no success either.
I tried precompiled yate 5.0.0 from ubuntu 14.04 repository, 5.5.1 from Silver connection PPA and compiled from  latest SVN source. Everything is the same.
I tried two different internet providers. Both are giving bandwidth enough to stream HD video stream. No success.
What drives me really crazy - I did exactly the same setup a month ago with 3G modem uplink in one day! No troubles! Sound is clear.
Can somebody tell me what can go wrong???
Title: Re: RTP is silenced every second
Post by: ktrofimov on May 03, 2016, 07:13:01 AM
Problem is solved
Sound was generated from another computer, but stream was not consistent: packets were sent in batches - 25 packets at once an then silence for 0.5s
Mobile apps like CSipSimple and Zoiper are able to reconstruct this jammed stream, but PSTN gates are not, resulting in jammed sound.
With another steaming application problem is gone.
Title: Re: RTP is silenced every second
Post by: ktrofimov on July 13, 2016, 10:26:59 AM
Still some troubles...
Is there a way to setup Yate RTP for strict 20ms timing?
Wireshark shows 0 to 50ms delays in RTP stream from Yate server

Hardware: Intel Core 2 Quad CPU Q6600 @ 2.4GHz, RAM: 6GB, Ubuntu 14.04 LTS

Looking at the Wireshark graphs it shows that jitter is kept at 20ms level, not delta
Graph are showing Jitter and Delta levels. Yate jitter is at 20ms, but it has to be as low as possible. While delta has to be always at 20ms but it jumps kile crazy.
Delta in Yate RTP stream is jumping 0, 30, 0,51, 0, 40, 0 35 ms
Reverse stream is pretty even: 19.8, 20.2, 20.1, 19.3, 20.5...
My setup is a conference call. One client is a SIP-softphone, another - VoIP/PSTN gateway.
Streams from clients to yate are pretty good, reverse streams from yate are not clear.
Especially it is important for PSTN gateway because it has no buffer and requires smooth stream

What can i do???