Author Topic: Database Modules  (Read 1591 times)

vankooch

  • Administrator
  • Newbie
  • *****
  • Posts: 49
    • View Profile
Database Modules
« on: January 16, 2013, 07:34:59 AM »
Hello,

I've a strange error with the mysql and the postgre modules. When I start up yate I've got this warnings:

Code: [Select]
<WARN> /usr/lib/x86_64-linux-gnu/yate/mysqldb.yate: file too short
.....
<WARN> /usr/lib/x86_64-linux-gnu/yate/pgsqldb.yate: file too short

but yate does load the modules and they work:

Code: [Select]
<ALL> Plugin::Plugin("mysqldb",true) [0x7ff36291c080]
Loaded module MySQL based on 5.5.28
....
<ALL> Plugin::Plugin("pgsqldb",true) [0x7ff361554080]
Loaded module PostgreSQL
....
Initializing module PostgreSQL
<pgsqldb:INFO> Database account 'dbmain' created poolsize=10 [0x2315470]
<pgsqldb:ALL> 'dbmain.1' intializing connection "host='xxx.xxx.xxx.xxx' port='5432' dbname='xxx' user='xxx' password='xxx'" retry 1 [0x2315470]
<pgsqldb:ALL> Connection for 'dbmain.1' succeeded [0x2315470]
....

The modules do work, we use them from register(cdr,..) and javascript module
I wonder if the waring is just an bug or if my build are not correct, which would be strange because the modules do work...

btw. I'm running on Ubuntu 12.04 LTS with Yate 4.3 (same error with 4.2)

Thanks for the help
« Last Edit: January 16, 2013, 07:42:22 AM by vankooch »