Author Topic: Can't start Yate with BladeRF  (Read 14940 times)


  • Newbie
  • *
  • Posts: 2
    • View Profile
Can't start Yate with BladeRF
« on: August 09, 2016, 11:09:51 AM »
Hi all,

I've been trying for a few weeks to get Yate started with my new BladeRF. I've tried several versions, below you'll find all info and logs. Any ideas?
I'm running Ubuntu.

Here is a link to the complete start log

mattias@bonbon:~$ bladeRF-cli -e info -e version

  Serial #:                 2536f44a366604e9ef4bd6ffee0046d7
  VCTCXO DAC calibration:   0x8f08
  FPGA size:                40 KLE
  FPGA loaded:              yes
  USB bus:                  4
  USB address:              3
  USB speed:                SuperSpeed
  Backend:                  libusb
  Instance:                 0

  bladeRF-cli version:        1.3.1-0.2016.01~rc1-3
  libbladeRF version:         1.5.1-0.2016.01~rc1-3

  Firmware version:           1.9.0
  FPGA version:               0.1.2

mattias@bonbon:~$ yate-config --version

mattias@bonbon:~$ ls -la $(yate-config --modules)/server/bts/
total 2712
drwxr-xr-x 2 root root    4096 jul 17 18:19 .
drwxr-xr-x 3 root root    4096 jul 17 18:34 ..
-rwxr-xr-x 1 root root 2765928 jul 17 18:19 mbts

mattias@bonbon:~$ yate -vvvvvv -CDoa
Yate (15940) is starting Tue Jul 19 10:26:18 2016
##Had to delete some to fit the message in the forum##
Loaded module Radius client
2016-07-19_10:26:18.245730 <ALL> Plugin::Plugin("ybts",false) [0x7f841ae45760]
Loaded module YBTS
2016-07-19_10:26:18.245876 <ALL> Plugin::Plugin("dbpbx",false) [0x7f841abf42a0]
Loaded module PBX for database
2016-07-19_10:26:18.245960 <ALL> Plugin::Plugin("park",false) [0x7f841a9ec240]
Loaded module Call Parking
2016-07-19_10:26:18.255864 <ALL> Plugin::Plugin("pgsqldb",true) [0x7f841a7e63a0]
Loaded module PostgreSQL
2016-07-19_10:26:18.256039 <ALL> Plugin::Plugin("accfile",false) [0x7f84163b9240]
Loaded module Accounts from file
2016-07-19_10:26:18.257520 <ALL> Plugin::Plugin("snmpagent",false) [0x7f84161b2fa0]
Loaded module SNMP Agent
2016-07-19_10:26:18.257698 <ALL> Plugin::Plugin("analog",false) [0x7f8415f71660]
Loaded module Analog Channel
2016-07-19_10:26:18.257789 <ALL> Plugin::Plugin("callcounters",false) [0x7f8415d581c0]
Loaded module CallCounters
2016-07-19_10:26:18.257921 <ALL> Plugin::Plugin("sqlitedb",true) [0x7f8415b52380]
Loaded module SQLite based on 3.11.0
2016-07-19_10:26:18.258015 <ALL> Plugin::Plugin("lateroute",false) [0x7f8415949220]
Loaded module Late Router
2016-07-19_10:26:18.258206 <ALL> Plugin::Plugin("mgcpgw",false) [0x7f84157441c0]
Loaded module MGCP-GW
2016-07-19_10:26:18.258307 <ALL> Plugin::Plugin("presence",false) [0x7f84155292a0]
Loaded module Presence
2016-07-19_10:26:18.258398 <ALL> Plugin::Plugin("ccongestion",false) [0x7f84153202c0]
Loaded module CCongestion
2016-07-19_10:26:18.258537 <ALL> Plugin::Plugin("register",false) [0x7f841511a620]
Loaded module Register for database
2016-07-19_10:26:18.258836 <ALL> Plugin::Plugin("jabber",true) [0x7f8414f0bd40]
Loaded module Jabber Server
2016-07-19_10:26:18.258977 <ALL> Plugin::Plugin("jbfeatures",true) [0x7f8414ce1400]
Loaded module Jabber Server Features
2016-07-19_10:26:18.259120 <ALL> Plugin::Plugin("dummyradio",true) [0x7f8414ad5740]
Loaded module DummyRadio
2016-07-19_10:26:18.259144 <ALL> Loaded 73 plugins
Initializing plugins
Initializing module DummyRadio
Initializing module Jabber Server Features
Initializing module Jabber Server
2016-07-19_10:26:18.259349 <jabber:ALL> JBPendingWorker(0) start running [0x208e070]
Initializing module SQLite
Initializing module PostgreSQL
Initializing module Subscriptions
Initializing module Cisco SM
Initializing module Cpu
2016-07-19_10:26:18.259707 <cpuload:NOTE> Updating CPU core number from 1 to 4
Initializing module Analog Detector
Initializing module Clustering
Initializing module MGCP Call Agent
2016-07-19_10:26:18.259861 <mgcpca:ALL> No gateways defined so module not initialized.
2016-07-19_10:26:18.260817 <mgcpca:ALL> Initialized audio codecs: mulaw,alaw,slin,ilbc20,ilbc30,isac/16000,isac/32000
Initializing module Event Logs
Initializing module DbWave
Initializing module SigTransport
Initializing module Javascript
2016-07-19_10:26:18.262749 <javascript:INFO> Parsed 'eliza' script: /usr/local/share/yate/scripts/eliza.js
Initializing module OpenSSL
Initializing module CdrFile
Initializing module MUX
Initializing module YSOCKS
2016-07-19_10:26:18.264715 <socks:INFO> Initialized auth-timeout=10000ms reply-timeout=30000ms print-msg=false print-extended=false
Initializing module ZLib
2016-07-19_10:26:18.264760 <zlibcompress:ALL> Initialized compressor_buflen=256 decompressor_buflen=1024 compress_level=default
Initializing module ToneDetector
Initializing module Call Forker
2016-07-19_10:26:18.264817 <callfork:INFO> Default fork for 'chan.dtmf' matching 'peerid' priority 100
Initializing module ToneGen
##Had to delete some ToneDesc stuff to fit the message##
2016-07-19_10:26:18.323671 <tone:ALL> ToneDesc(za/stutter) initializing from '!400*33/100,!0/100,!400*33/100,!0/100,!400*33/100,!0/100,!400*33/100,!0/100,!400*33/100,!0/100,!400*33/100,!0/100,400*33' [0x2237740]
Initializing module Conference
Initializing module PBX
Initializing module FileInfo
Initializing module Call Generator
Initializing module MsgSniffer
2016-07-19_10:26:18.323981 <CallGen:INFO> CleanThread::run() [0x2181be0]
2016-07-19_10:26:18.324059 <INFO> Registered broadcast message handler 0x2181f20
Initializing module DumbChannel
DumbChannel initialized
Initializing module CdrBuild
Initializing module YRTP
Initializing module GVoice
Initializing module WaveFile
Initializing module Analyzer
Initializing module YSTUN
2016-07-19_10:26:18.324502 <stun:ALL> Bind request interval set to 15000 msec.
Initializing module SIP Channel
2016-07-19_10:26:18.324653 <sip:ALL> Initialized audio codecs: mulaw,alaw,slin,ilbc20,ilbc30,isac/16000,isac/32000
2016-07-19_10:26:18.324715 <sip:ALL> YateSIPEndPoint::YateSIPEndPoint(normal) [0x217f190]
2016-07-19_10:26:18.324806 <sip:ALL> Transport(general) created [0x217a530]
2016-07-19_10:26:18.324829 <sip:ALL> Listener(UDP,'general') initialized addr=':5060' default=true maxpkt=1500 rtp_localip=(null) nat_address=(null) [0x217a530]
2016-07-19_10:26:18.324862 <sip:INFO> Default UDP transport is 'general'
Initializing module iLBC webrtc
2016-07-19_10:26:18.324884 <sip:ALL> Listener(UDP,'general') initializing socket addr='(null)' port=5060
Initializing module RegexRoute
2016-07-19_10:26:18.324961 <sip:INFO> Listener(UDP,'general') started on ':5060' (IPv4)
Initializing module RManager
2016-07-19_10:26:18.325066 <RManager:INFO> Starting listener 'general' on
Initializing module File Transfer
2016-07-19_10:26:18.325181 <filetransfer:INFO> Initialized send_chunk_size=4096 send_interval=50ms send_linger_intervals=20 notify_progress=false
Initializing module iSAC
Initializing module YJingle
2016-07-19_10:26:18.325426 <jingle:ALL> YJGEngineWorker start running
2016-07-19_10:26:18.325453 <jgengine:ALL> Jingle engine initialized: jingle_flags=0 stanza_timeout=20000 ping_interval=300000 [0x2239ec0]
2016-07-19_10:26:18.325494 <jingle:NOTE> Module initialized: localip=MISSING jingle_version=1 singletone=true pending_timeout=10000 anonymous_caller=unk_caller codecs=mulaw,alaw
Initializing module YIAX
2016-07-19_10:26:18.325580 <iax:ALL> Enabled audio format(s) 'ilbc30,mulaw,alaw,slin' default=slin
2016-07-19_10:26:18.325601 <iax:ALL> No video format(s) available
2016-07-19_10:26:18.325709 <iaxengine:INFO> Bound on '' [0x223ee50]
2016-07-19_10:26:18.325730 <iaxengine:ALL> Adjust ts out set to thres=120 over=120 under=60 [0x223ee50]
2016-07-19_10:26:18.325748 <iaxengine:INFO> Status changed Idle -> Listening [0x223ee50]
2016-07-19_10:26:18.325760 <iax:INFO> Added listener (0x223ee50) 'iaxengine' status='Listening'
2016-07-19_10:26:18.325813 <iaxengine:ALL> Created 3 'YIAXListener' threads [0x223ee50]
2016-07-19_10:26:18.325861 <iaxengine:ALL> Created 3 'YIAXGetEvent' threads [0x223ee50]
2016-07-19_10:26:18.325891 <iaxengine:ALL> Created 1 'YIAXTrunking' threads [0x223ee50]
2016-07-19_10:26:18.325912 <iax:INFO> Default listener is 'iaxengine'
Initializing module MOH
Initializing module CdrCombine
Initializing module ExtModule
Initializing module Queues for database
Initializing module SIP Features
2016-07-19_10:26:18.326139 <sipfeatures:ALL> Allowed subscriptions: dialog,message-summary
Initializing module Monitoring
2016-07-19_10:26:18.326321 <monitoring:ALL> RTPTable created [0x224d730]
2016-07-19_10:26:18.326339 <monitoring:ALL> RTPTable [0x224d730] configured with directions='(null)',resetTime=3600
Initializing module Queues Notify
2016-07-19_10:26:18.326392 <queuesnotify:INFO> Query 'callinfo' not configured
2016-07-19_10:26:18.326405 <queuesnotify:INFO> Query 'cdrinfo' not configured
2016-07-19_10:26:18.326420 <queuesnotify:ALL> Initialized: account= notifyhanguponunload=true
Initializing module Signalling Channel
2016-07-19_10:26:18.326726 <sig/isup.decode:INFO> ISUP Call Controller pointcode-type=ITU format=alaw plan/type/pres/screen=unknown/unknown/allowed/user-provided caller-category=ordinary remote-pointcode=1-1-1 SIF/SSF=5/128 lockcircuits= userpartavail=false lockgroup=true mediareq=no outboundsls=cic [0x224ffd0]
2016-07-19_10:26:18.326769 <sig/isup.encode:INFO> ISUP Call Controller pointcode-type=ITU format=alaw plan/type/pres/screen=unknown/unknown/allowed/user-provided caller-category=ordinary remote-pointcode=1-1-1 SIF/SSF=5/128 lockcircuits= userpartavail=false lockgroup=true mediareq=no outboundsls=cic [0x2251160]
2016-07-19_10:26:18.326818 <sig:NOTE> Section 'tcapuser_test'. Unknown/missing type '(null)'
Initializing module Cache
Initializing module Users Management
Initializing module MrcpSpeech
Initializing module Register from file
Initializing module GSM Transceiver
2016-07-19_10:26:18.327491 <gsmtrx:INFO> Socket(control) bound on (remote: [0x2257070]
2016-07-19_10:26:18.327526 <gsmtrx:INFO> Module state changed Idle -> Waiting
Initializing module Radius client
2016-07-19_10:26:18.327649 <yradius:NOTE> Local address not set or invalid. Radius functions disabled
Initializing module YBTS
2016-07-19_10:26:18.327926 <ybts:INFO> LAI changed (null) -> 00101_03e8
Initializing module PBX for database
Initializing module Call Parking
Initializing module Accounts from file
Initializing module SNMP Agent
2016-07-19_10:26:18.332501 <snmpagent:ALL> SnmpMsgQueue created for with priority 'normal'
2016-07-19_10:26:18.332551 <snmpagent:INFO> SNMP UDP Listener initialized on port 20161
Initializing module Analog Channel
Initializing module Late Router
Initializing module MGCP Gateway
2016-07-19_10:26:18.333006 <mgcp_gw:INFO> Initialized:
type:              Gateway
bind address:      :2427
allow_unknown_cmd: false
retrans_interval:  250000
retrans_count:     3
lower_case_params: true
max_recv_packet:   1500
send_provisional:  true
2016-07-19_10:26:18.333062 <mgcpgw:ALL> Initialized audio codecs: mulaw,alaw,slin,ilbc20,ilbc30,isac/16000,isac/32000
Initializing module Presence
2016-07-19_10:26:18.333152 <presence:ALL> Initialized lists=16 expirecheck=0 expiretime=0 account=(null)
Initializing module CCongestion
Initializing module Register for database
Initialization complete
2016-07-19_10:26:18.333269 <ALL> Engine dispatching start message
2016-07-19_10:26:18.333371 <ybts:NOTE> State changed Idle -> Starting restart counter 1/10
2016-07-19_10:26:18.333413 <transceiver:ALL> Started worker thread [0x226e010]
2016-07-19_10:26:18.333433 <transceiver:INFO> Started [0x226e010]
2016-07-19_10:26:18.333467 <mbts:ALL> Started worker thread [0x226e250]
2016-07-19_10:26:18.333486 <mbts:INFO> Started [0x226e250]
2016-07-19_10:26:18.333505 <ybts-command:INFO> Started [0x226e4b0]
2016-07-19_10:26:18.333538 <ybts-signalling:ALL> Started worker thread [0x226e8f0]
2016-07-19_10:26:18.333556 <ybts-signalling:INFO> Started [0x226e8f0]
2016-07-19_10:26:18.333590 <ybts-media:ALL> Started worker thread [0x226e610]
2016-07-19_10:26:18.333608 <ybts-media:INFO> Started [0x226e610]
2016-07-19_10:26:18.333624 <ybts:ALL> Starting peer '/usr/local/lib/yate/server/bts/mbts' '(null)'
2016-07-19_10:26:18.334197 <ybts:INFO> Started peer pid=15969
2016-07-19_10:26:18.334262 <ybts:NOTE> State changed Starting -> WaitHandshake
2016-07-19_10:26:18.334291 <ybts:ALL> Restart scheduled in 120000ms [0x7f841ae45760]
MBTS connected to YBTS
Yate-BTS MBTS Component
Copyright 2008, 2009, 2010 Free Software Foundation, Inc.
Copyright 2010 Kestrel Signal Processing, Inc.
Copyright 2011, 2012, 2013 Range Networks, Inc.
Copyright 2013, 2014 Null Team Impex SRL
Copyright 2014 Legba, Inc.
"OpenBTS" is a registered trademark of Range Networks, Inc.

  SC Null Team Impex SRL:
    Paul Chitescu
  Legba, Inc.
    David Burgess
  Range Networks, Inc.:
    David Burgess, Harvind Samra, Donald Kirker, Doug Brown,
    Pat Thompson, Kurtis Heimerl
  Kestrel Signal Processing, Inc.:
    David Burgess, Harvind Samra, Raffi Sevlian, Roshan Baliga
  GNU Radio:
    Johnathan Corgan
    Anne Kwong, Jacob Appelbaum, Joshua Lackey, Alon Levy
    Alexander Chemeris, Alberto Escudero-Pascual
Incorporated L/GPL libraries and components:
  libusb, LGPL 2.1, various copyright holders,
Incorporated BSD/MIT-style libraries and components:
  A5/1 Pedagogical Implementation, Simplified BSD License,
    Copyright 1998-1999 Marc Briceno, Ian Goldberg, and David Wagner
Incorporated public domain libraries and components:
  sqlite3, released to public domain 15 Sept 2001,

This program comes with ABSOLUTELY NO WARRANTY.

Use of this software may be subject to other legal restrictions,
including patent licensing and radio spectrum licensing.
All users of this software are expected to comply with applicable
regulations and laws.  See the LEGAL file in the source code for
more information.

Release 5.0.1 formal build date Jul 17 2016 rev586
2016-07-19_10:26:18.344597 <mbts:NOTE> GSMConfig.cpp:80:regenerateBeacon: regenerating system information messages, changemark 1
Starting MBTS...
2016-07-19_10:26:18.345080 <ybts-signalling:INFO> Received [0x226e8f0]
Primitive: Handshake
Info: 0
2016-07-19_10:26:18.345121 <ybts:NOTE> State changed WaitHandshake -> Running
2016-07-19_10:26:18.345161 <ybts-signalling:INFO> Sending [0x226e8f0]
Primitive: Handshake
Info: 0
2016-07-19_10:26:18.345237 <gsmtrx:GOON> Failed to create radio interface: Message not handled
ALERT 140670099449664 10:26:18.3 TRXManager.cpp:135:sendCommand: RESET failed with status 2
2016-07-19_10:26:18.345356 <mbts:WARN> TRXManager.cpp:135:sendCommand: RESET failed with status 2
ALERT 140670099449664 10:26:18.3 OpenBTS.cpp:250:main: Failed to reset transceiver
2016-07-19_10:26:18.345423 <mbts:WARN> OpenBTS.cpp:250:main: Failed to reset transceiver
2016-07-19_10:26:18.356116 <javascript:INFO> Parsed 'nib' script: /usr/local/share/yate/scripts/nib.js
2016-07-19_10:26:18.358434 <nib:INFO> Finished reading saved registered subscribers. Found 0 registered_subscribers.
2016-07-19_10:26:18.358647 <nib:INFO> Checked that only NIB is enabled.
2016-07-19_10:26:18.358686 <ALL> Rescanning handler list for 'engine.start' [0x7ffc578d9330] at priority 100
Yate engine is initialized and starting up on bonbon
2016-07-19_10:26:18.358792 <INFO> Creating first 1 message dispatching threads
2016-07-19_10:26:19.261789 <cpuload:NOTE> Updating CPU core number from 1 to 4
2016-07-19_10:26:22.000624 <ybts:NOTE> Peer pid 15969 vanished
2016-07-19_10:26:22.000681 <ybts:ALL> Restart scheduled in 1ms [0x7f841ae45760]
2016-07-19_10:26:22.000699 <ybts:ALL> Scheduled stop in 0ms
2016-07-19_10:26:23.003971 <ybts:NOTE> 'shutdown' command failed
2016-07-19_10:26:23.004019 <ybts:ALL> Stopping ...
2016-07-19_10:26:23.008805 <ybts-signalling:ALL> Worker thread terminated [0x226e8f0]
2016-07-19_10:26:23.009165 <ybts-signalling:INFO> Stopped [0x226e8f0]
2016-07-19_10:26:23.014079 <ybts-media:ALL> Worker thread terminated [0x226e610]
2016-07-19_10:26:23.014339 <ybts-media:INFO> Stopped [0x226e610]
2016-07-19_10:26:23.014433 <ybts-command:INFO> Stopped [0x226e4b0]
2016-07-19_10:26:23.019055 <transceiver:ALL> Worker thread terminated [0x226e010]
2016-07-19_10:26:23.019573 <transceiver:INFO> Stopped [0x226e010]
2016-07-19_10:26:23.024123 <mbts:ALL> Worker thread terminated [0x226e250]
2016-07-19_10:26:23.024689 <mbts:INFO> Stopped [0x226e250]
2016-07-19_10:26:23.024710 <ybts:NOTE> State changed Running -> Idle
2016-07-19_10:26:24.002217 <ybts:NOTE> State changed Idle -> Starting restart counter 2/10
2016-07-19_10:26:24.002416 <transceiver:ALL> Started worker thread [0x226e010]
2016-07-19_10:26:24.002469 <transceiver:INFO> Started [0x226e010]
2016-07-19_10:26:24.002642 <mbts:ALL> Started worker thread [0x226e250]
2016-07-19_10:26:24.002683 <mbts:INFO> Started [0x226e250]
2016-07-19_10:26:24.002790 <ybts-command:INFO> Started [0x226e4b0]
2016-07-19_10:26:24.002888 <ybts-signalling:ALL> Started worker thread [0x226e8f0]
2016-07-19_10:26:24.002923 <ybts-signalling:INFO> Started [0x226e8f0]
2016-07-19_10:26:24.003009 <ybts-media:ALL> Started worker thread [0x226e610]
2016-07-19_10:26:24.003038 <ybts-media:INFO> Started [0x226e610]
2016-07-19_10:26:24.003068 <ybts:ALL> Starting peer '/usr/local/lib/yate/server/bts/mbts' '(null)'
2016-07-19_10:26:24.004092 <ybts:INFO> Started peer pid=16028
2016-07-19_10:26:24.004129 <ybts:NOTE> State changed Starting -> WaitHandshake
2016-07-19_10:26:24.004155 <ybts:ALL> Restart scheduled in 120000ms [0x7f841ae45760]
....and then the lastest part is repeated 10 times.

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Re: Can't start Yate with BladeRF
« Reply #1 on: August 10, 2016, 01:56:43 AM »
It seems that the BladeRF module (ybladerf.yate) is missing. (See :

If you compiled and installed yate by yourself, you might not have had the libusb-1.0-devel support at configure time. Install the development libraries for libusb-1.0, reconfigure Yate (and you can check in config log that libusb was detected) and re-compile, reinstall.
After this, check that in yate_src/modules/radio/ you have ybladerf.yate

If still that doesn't work, please post how you installled yate, how you started it,  Yate version and YateBTS version and the output of 'status' command in the telnet console of yate.
« Last Edit: August 10, 2016, 02:43:46 AM by Ioana Stanciu »


  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Can't start Yate with BladeRF
« Reply #2 on: August 10, 2016, 05:14:29 AM »
Thanks a lot for your help!

Initially it seems like the problems is solved, I just did this seconds ago and will post more info.

For everyone else, this is what I did:
sudo apt-get install libusb-1.0-0-dev

checking for libusb in /usr... yes

sudo make install-noapi

mattias@bonbon:~/software/null/yate$ yate -s
Supervisor (20107) is starting
Yate (20108) is starting Wed Aug 10 13:05:08 2016
Loaded modules..... #removed all modules before paste#
Loaded module BladeRF using libusb desc=''
Initializing plugins
Initialization complete
MBTS connected to YBTS
Yate-BTS MBTS Component
Copyright 2008, 2009, 2010 Free Software Foundation, Inc.
Copyright 2010 Kestrel Signal Processing, Inc.
Copyright 2011, 2012, 2013 Range Networks, Inc.
Copyright 2013, 2014 Null Team Impex SRL
Copyright 2014 Legba, Inc.
"OpenBTS" is a registered trademark of Range Networks, Inc.

Release 5.0.1 formal build date Jul 17 2016 rev586
Starting MBTS...
Yate engine is initialized and starting up on bonbon
2016-08-10_13:05:08.687922 <WARN> Failed to create thread with priority 3, trying with inherited
MBTS ready
2016-08-10_13:06:43.088432 <bladerf/1:WARN> RX: timestamp jumped by 12675 to 204521475 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:06:43.112796 <bladerf/1:WARN> RX: timestamp jumped by 12577 to 204560566 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:06:43.113609 <bladerf/1:WARN> RX: timestamp jumped by 4309 to 204583303 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:06:44.892117 <bladerf/1:WARN> RX: timestamp jumped by 1827 to 208440284 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:06:53.027825 <bladerf/1:WARN> RX: timestamp jumped by 1549 to 226068008 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:06:53.922555 <bladerf/1:WARN> RX: timestamp jumped by 1179 to 228006954 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:06:59.096313 <bladerf/1:WARN> RX: timestamp jumped by 1601 to 239214613 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:07:01.524099 <bladerf/1:WARN> RX: timestamp jumped by 6283 to 244470966 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:07:07.735382 <bladerf/1:WARN> RX: timestamp jumped by 5797 to 257922993 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:07:16.071248 <bladerf/1:WARN> RX: timestamp jumped by 1167 to 275995302 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:07:16.086774 <bladerf/1:WARN> RX: timestamp jumped by 13828 to 276016789 in buffer 2/4 [0x7f4c74001030]
2016-08-10_13:07:16.299455 <bladerf/1:WARN> RX: timestamp jumped by 1596 to 276489849 in buffer 2/4 [0x7f4c74001030]

So far what I can see is a network called 00101. I believe this may be the right one.
Further info will come, thanks again!

My goal is to be able to connect to this network, and route my own calls to the real network via a better antenna. I have very bad reception here :)


  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Can't start Yate with BladeRF
« Reply #3 on: March 26, 2020, 12:09:10 AM »
good evening. Did you manage to make the bladerf XA4 run with yate?
« Last Edit: March 26, 2020, 12:14:48 AM by fnassaf »