Author Topic: YateBTS + bladeRF unstable  (Read 1410 times)

sertys

  • Newbie
  • *
  • Posts: 5
    • View Profile
YateBTS + bladeRF unstable
« on: August 22, 2016, 08:05:58 AM »
I am running the latest Yate + YateBTS from releases page and trying to run my little base station.
Going through a lot of combinations of FPGAs and firmwares got stuck with :
bladeRF-cli version:        1.4.0-2016.06-1-ppatrusty
  libbladeRF version:         1.7.2-2016.06-1-ppatrusty

  Firmware version:           1.6.1-git-053fb13-buildomatic
  FPGA version:               0.0.3
as it at least starts my BTS and i can find it on the phones.
The problem however is that it is extremely unstable, runs for a couple of minutes and then gives me :
2016-08-22_17:02:47.744776 <transceiver:MILD> bladeRFDevice.cpp:611:writeSamples: Samples TX failed at 86288881: Operation timed out
2016-08-22_17:02:48.245020 <transceiver:MILD> bladeRFDevice.cpp:611:writeSamples: Samples TX failed at 86289389: Operation timed out
2016-08-22_17:02:48.745280 <transceiver:MILD> bladeRFDevice.cpp:611:writeSamples: Samples TX failed at 86289897: Operation timed out
CRIT 3048450880 17:02:49.2 bladeRFDevice.cpp:948:checkHealth: Excessive I/O errors, bailing out
Received shutdown signal
2016-08-22_17:02:49.245485 <transceiver:MILD> bladeRFDevice.cpp:611:writeSamples: Samples TX failed at 86290405: Operation timed out
Shutting down transceiver...
2016-08-22_17:02:49.246300 <transceiver:WARN> bladeRFDevice.cpp:948:checkHealth: Excessive I/O errors, bailing out
EMERG 3074349888 17:02:49.2 OpenBTS.cpp:159:startTransceiver: Transceiver quit with status 0. Exiting.

Which basically kills the transceiver and restarts it over. Can you shoot me some pointers onto how to fix the issues and have a stable BTS at hand?

sertys

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: YateBTS + bladeRF unstable
« Reply #1 on: August 24, 2016, 05:14:05 PM »
As pointed in the IRC channel, this issue is due to a low cpu and/or usb3 drivers on a ubuntu system.
I changed the host to a more powerful one (i5 cpu and proper usb3) and it is running without a hitch now.

mjidhage

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: YateBTS + bladeRF unstable
« Reply #2 on: November 03, 2017, 03:31:34 AM »
Hi there,

Experiencing the exact same problems. I am running an i5 so CPU is not a problem. Looking at lsusb -t and usb-devices it looks like Im running USB3. Switching to "proper usb3" was a recommendation in the thread - in an ubuntu-context; what is proper USB3? External drivers not part of Ubuntu distro?

brgsd/Mattias