Author Topic: Trouble with subscribers expiring  (Read 1819 times)

herman1199

  • Newbie
  • *
  • Posts: 6
    • View Profile
Trouble with subscribers expiring
« on: December 19, 2016, 05:53:29 AM »
I'm struggling with a YateBTS/BladeRF problem and looking for some help.

I have a BladeRFx40, Ubuntu 14.04, Yate 5.5.1-devel1 r6155
I have 2 phones that can establish a connection with the Yate network but I cannot get the system to retain the connection. They will consistently disconnect with a few seconds. I'm happy that the various pieces are all in place and I can send a sms to Eliza in the short window where I have connection.

The handsets still claim to be registered but NIB on web and through Telnet do not list them.
If I leave them idle with Yate running they will periodically re-register and another welcome sms is received. This is roughly every 30 mins.

I have these 2 SIM configured with a regexp and I have tried changing Tmsi expire but I only ever get pretty much instant disconnect.
I have also tried calling david but that just hangs up right away.

Apart from Radio band/C0 all other configs are default.

I've added a log of start up, registration of 1 phone and that subscriber expiring but I can't see any errors or messages that look dodgy.

Any help appreciated
« Last Edit: December 19, 2016, 06:06:29 AM by herman1199 »

Monica Tepelus

  • Administrator
  • Full Member
  • *****
  • Posts: 194
    • View Profile
Re: Trouble with subscribers expiring
« Reply #1 on: December 19, 2016, 06:57:13 AM »
Hi,

There is a bug in nib.js that we didn't manage to fix yet. For the moment you can configure subscribers individually until we fix the regexp issue sometimes in january.

herman1199

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Trouble with subscribers expiring
« Reply #2 on: December 19, 2016, 07:24:17 AM »
That's great! Thanks for getting back so promptly. That's got me up and running.

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Trouble with subscribers expiring
« Reply #3 on: December 23, 2016, 01:11:31 PM »
why don't you try to use this version?

https://github.com/evilsocket/evilbts

after this installation It worked good for me