Author Topic: Connect Yate to Sangoma Vega 50 gateway  (Read 159 times)

Badhills

  • Newbie
  • *
  • Posts: 2
    • View Profile
Connect Yate to Sangoma Vega 50 gateway
« on: January 31, 2018, 03:58:13 AM »
Hi,

i'm trying to connect my sangoma Vega Gateway to Yate.

At this point the connection from gateway to Yate is active and inbound calls are working.

But the other way is not working.
I edited the accfile.conf as shown:

Code: [Select]
[isdn]
enabled=yes
protocol=sip
username=isdn
;server=192.168.170.205
description=Vega ISDN gateway
interval=50
;authname=isdn
password=********
domain=192.168.170.204
;registrar=192.168.170.205:5060
;outbound=192.168.170.205:5060
;localaddress=192.168.170.205:5060

I tried different options, so don't look at what is now commentet out. I tried everything.

I get this back from debugging:
Code: [Select]
------
2018-01-31_09:42:32.008071 <sip:INFO> 'udp:0.0.0.0:5060' sending 'REGISTER sip:192.168.170.205:5060' 0x7fcd58001ea0 to 192.168.170.205:5060 [0x16c27a0]
------
REGISTER sip:192.168.170.205:5060 SIP/2.0
Contact: "Vega ISDN gateway" <sip:isdn@192.168.170.204:5060>
Expires: 600
To: <sip:isdn@192.168.170.204>
Call-ID: 1063963234@192.168.170.204
Via: SIP/2.0/UDP 192.168.170.204:5060;rport;branch=z9hG4bK1234004868
From: "Vega ISDN gateway" <sip:isdn@192.168.170.204>;tag=1465067924
CSeq: 3 REGISTER
User-Agent: YATE/6.0.0
Max-Forwards: 70
Allow: ACK, INVITE, BYE, CANCEL, REGISTER, REFER, OPTIONS, INFO
Content-Length: 0

------
2018-01-31_09:42:32.012385 <sip:INFO> 'udp:0.0.0.0:5060' received 379 bytes SIP message from 192.168.170.205:5060 [0x16c27a0]
------
SIP/2.0 501 Not Implemented
Via: SIP/2.0/UDP 192.168.170.204:5060;rport=5060;branch=z9hG4bK1234004868
From: "Vega ISDN gateway" <sip:isdn@192.168.170.204>;tag=1465067924
To: <sip:isdn@192.168.170.204>;tag=0016-082B-9AFA118B
Call-ID: 1063963234@192.168.170.204
CSeq: 3 REGISTER
Contact: <sip:192.168.170.205:5060>
User-Agent: VEGAEURO/13.02.08.8xS068
Content-Length: 0

------
2018-01-31_09:42:32.013209 <sip:WARN> SIP line 'isdn' logon failure 501: Not Implemented

EDIT: I got "Not implemented" back, because the gateway needs a non-authorization and non-registrar connection. But how do i set this up in yate?

Has anybody an Idea?

kind regards,
Markus Badberg
« Last Edit: February 07, 2018, 05:54:42 AM by Badhills »