Author Topic: Can't installing yate on rasspberry Pi3  (Read 1531 times)

Vinsmoke Sanji

  • Newbie
  • *
  • Posts: 12
    • View Profile
Can't installing yate on rasspberry Pi3
« on: September 19, 2018, 12:40:46 AM »
Hello everyone, when i install yate on raspbian i get this error:

openssl.cpp: In member function ‘virtual bool {anonymous}::AesCtrCipher::encrypt(void*, unsigned int, const void*)’:
openssl.cpp:654:6: error: ‘AES_ctr128_encrypt’ was not declared in this scope &num);
      ^
Makefile:315: recipe for target 'openssl.yate' failed
make[1]: *** [openssl.yate] Error 1
make[1]: Leaving directory '/usr/src/yate/modules'
Makefile:186: recipe for target 'modules' failed
make: *** [modules] Error 2
Where i was wrong? Thank you.

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #1 on: September 19, 2018, 01:25:08 AM »
Please state YATE version and what version of OpenSSL you have on the raspberryPi.

Also please tell us what is the detected version of OpenSSL by  the configure script of YATE.

This looks like a mismatch between what is detected by the configure script for OpenSSL and what is actually installed. Maybe you updated OpenSSL and did not run configure again when compiling YATE?

Vinsmoke Sanji

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #2 on: September 19, 2018, 02:04:12 AM »
i install Yate from the link: https://gist.github.com/smarek/b538465a711edc7e6d7652c82e76d374 (i installed and run on ubuntu 16.04)
and version OpenSSL on raspberry:
root@raspberrypi:/home/pi# apt-cache policy openssl
openssl:
  Installed: 1.1.0f-3+deb9u2
  Candidate: 1.1.0f-3+deb9u2
  Version table:
 *** 1.1.0f-3+deb9u2 500
        500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
        100 /var/lib/dpkg/status

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #3 on: September 24, 2018, 01:38:55 AM »
There is a mismatch between your YATE version and the OpenSSL version. The OpenSSL API changed and the fix for it was committed to YATE in June 2018.
The YATE version you are trying to use from that repository is more than a year old.

You can get the up to date versions of Yate and YateBTS from the official repositories (those git repositories were just a clone of the SVN):
Code: [Select]
svn co http://voip.null.ro/svn/yate/trunk yate
svn co http://voip.null.ro/svn/yatebts/trunk/ yatebts

Make sure to clean up the previous installation.

Vinsmoke Sanji

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #4 on: September 25, 2018, 01:00:51 AM »
I already tried this one. When i installing, everything is ok but when i follow the path /usr/local/etc/yate i didn't saw file `ybts.conf` and `subscribers.conf`.

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #5 on: September 25, 2018, 01:24:16 AM »
Did you 'make install' for YateBTS?
If you did and the files are stil not there ( i dont think subscribers.conf is automatically installed), you can always copy them from the source or create them.
See https://wiki.yatebts.com/index.php/Javascript_NiPC

Vinsmoke Sanji

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #6 on: September 25, 2018, 01:58:46 AM »
Thanks for your help, I have successfully installed, but when running Yate I get "Bus error (core dumped)"  notice.

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #7 on: September 25, 2018, 06:21:42 AM »
Please post a log and configuration files.

kpz

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #8 on: September 25, 2018, 12:02:07 PM »
You gotta run off ubuntu 14

Vinsmoke Sanji

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Can't installing yate on rasspberry Pi3
« Reply #9 on: September 25, 2018, 09:42:00 PM »
Thanks Ioana Stanciu, I have successfully installed. ;D ;D ;D