Author Topic: bladeRF 2.0 micro xA4- Failed to open USB device: USB reset failed  (Read 556 times)

pjchavaux

  • Newbie
  • *
  • Posts: 5
    • View Profile
Hello,
I currently have (4) BTS towers setup and playing well together.  I have (1) BladeRF x115, (1) BladeRF x40, (1) Ettus B205mini and (1) Ettus N210.  All are running on Raspberry Pi. The Ettus products are running OpenBTS and the BladeRF cards are running the latest version of Yate/YateBTS.
I have recently bought a Nuand BladeRF 2.0 micro xA4. I have built Yate/YateBTS on a standard PC running Ubuntu 16.04 and on Raspberry Pi 3B running Jessie (2016-03-18).  Both builds run the x40 and x115 problem free, but when I connect the xA4 board I keep getting a "failed to reset transceiver error" and " Failed to open USB device: USB reset failed - no device found". The board detects perfectly in bladeRF-cli, dmesg and lsusb.  I've tried loading the FPGA just prior to running yate -s -vvv as was suggested in another post but I still get the "failed to reset transceiver error".  I built the the bladeRF library from sources :

git clone https://github.com/Nuand/bladeRF.git bladeRF
cd bladerf
cd host
mkdir build
cd build
cmake ../
make
make install
ldconfig

I've tried running it in three environments, (1) regular PC with USB3 running Ubuntu 16.04, (2) Raspberry Pi 3 B running Jessie (03-16-2016) and in a VirtualBox VM running Ubuntu Xenial and all three give me the same error, "failed to reset transceiver" and " Failed to open USB device: USB reset failed - no device found". When I exit yate and check bladeRF-cli, dmesg and lsusb the Nuand 2.0 micro is there.   

I built my first BTS in 2014 and have built dozens of them using the N210 and BladeRF x115/x40 products and have run into very few problems.  I've exhausted all the posts listed on Google under "bladerf failed to reset transceiver" and " Failed to open USB device: USB reset failed - no device found" and read most of the forum posts on Yate Forum back to 2017 and haven't been able to fix the problem.  There are only about (4) posts on the subjects and none have been any help.

I would appreciate it if anyone who has successfully gotten a BladeRF 2.0 micro xA4 to work with YateBTS could pass on any tricks or tips they used to get it to work.  I would also appreciate it if anyone has any suggestions I could try, that would be a big help.

I'm not boring you with long output logs as I've been using YateBTS installations that work with the other two Nuand BladeRF boards (x40 and x115).  I have tried other versions of Yate back to version 5.0 and they also give the same two errors.  The bladeRF transceiver is set using the web interface and I am using the standard 900mhz frequency and 51 Radio.C0.  I've left all settings to their defaults except OpenRegistration set to .* and RxGain set to 10.  These settings work fine with the other two BladeRF boards.

Thanks in advance for any help you can give me.
Paul C.

pjchavaux

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: bladeRF 2.0 micro xA4- Failed to open USB device: USB reset failed
« Reply #1 on: July 06, 2019, 12:38:03 PM »
Here is by bladeRF-cli readout

bladeRF> info

  Board:                    Nuand bladeRF 2.0 (bladerf2)
  Serial #:                 f6790e09fb524861ad9f20bfc9f743f2
  VCTCXO DAC calibration:   0x203f
  FPGA size:                49 KLE
  FPGA loaded:              yes
  Flash size:               32 Mbit
  USB bus:                  2
  USB address:              3
  USB speed:                SuperSpeed
  Backend:                  libusb
  Instance:                 0

bladeRF>

pjchavaux

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: bladeRF 2.0 micro xA4- Failed to open USB device: USB reset failed
« Reply #2 on: July 21, 2019, 02:52:00 PM »
UPDATE
I was able to get the BladeRF 2.0 micro working with yate-rc build on Ubuntu 18 VM.  I can see it from my phone but I am unable to connect to it?
Any help would be appreciated.
Thanks

coding_luke

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: bladeRF 2.0 micro xA4- Failed to open USB device: USB reset failed
« Reply #3 on: August 05, 2019, 06:08:21 AM »
Hey pjchavaux,
I'm also running the bladerf micro a4 with yate-rc and Ubuntu 16 in VM. I'm also facing this problem. Do you have any updates on this?