Author Topic: BladeRF2.0 (xA4) - Incompatible with YateBTS?  (Read 237 times)

ssnake_br

  • Newbie
  • *
  • Posts: 1
    • View Profile
BladeRF2.0 (xA4) - Incompatible with YateBTS?
« on: January 17, 2019, 08:06:36 PM »
Hey Guys,

After a lot of research and confusion, I ended in a post talking about the xA4 incompatibility with YateBTS. Is that true?
I mean, SH***T, I was dumb enough to spent $600 and three weeks to import this device to my country and now I am almost crying LOL.

Sorry for create a post about this, but the info I found is not precise about this incompatibility.

Thank you!

silodk

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: BladeRF2.0 (xA4) - Incompatible with YateBTS?
« Reply #1 on: February 21, 2019, 07:46:01 AM »
Hi,

I have the same problem.
I have bought 2 of the xA4 and having problems with transmitting both with a lot of sdr programs and make it work with yate.
I'm thinking of selling the bladerf's as I can't use it. :(

Anyone who has info about making it work?

jhutchins

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: BladeRF2.0 (xA4) - Incompatible with YateBTS?
« Reply #2 on: February 26, 2019, 05:24:02 PM »
I tried following these instructions: https://nuand.com/forums/viewtopic.php?f=5&t=5094&p=9388#p9388 and I made sure I was using that particular FPGA image. I can now see the operator on my mobile phone but can't connect. Getting TOA errors such as here: https://nuand.com/forums/viewtopic.php?f=4&t=4140&p=9419#p9419. I have no idea if there are any plans to fix this but I already sold my x40 and now only have an xA4 so I hope so bc I have no idea where to even begin if I need to fix it myself... I haven't tried since January so maybe it's fixed by now? Back then I tried a couple different motherboards (with different USB controllers) and different versions of ubuntu. The x40 worked fine on both setups before...