Author Topic: Phone doesn't auto connect to yatebts  (Read 121 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
Phone doesn't auto connect to yatebts
« on: June 13, 2019, 01:11:49 PM »
Hello, I am trying to make a working bts with yate, but phones won't connect automatically, and if I try to manual connect to my network it takes long time and in the end it says network not available..also the command in telnet nipc list registered is empty..but nipc list rejected also is empty.
The carrier stays up and fine at my downlink frequency until i issue the stop command, checked using gqrx with another antenna.
I am using the bladerfxA4 and followed these instructions for installation
my system is Lubuntu 18.04 on an intel i3 4 cores pc.
these are the bladerf info:
Code: [Select]
bladeRF-cli -i                         
bladeRF> info

  Board:                    Nuand bladeRF 2.0 (bladerf2)
  Serial #:                 e83faffdb85549168c18361f48767805
  VCTCXO DAC calibration:   0x1fbb
  FPGA size:                49 KLE
  FPGA loaded:              yes
  Flash size:               32 Mbit (assumed)
  USB bus:                  2
  USB address:              5
  USB speed:                Hi-Speed
  Backend:                  libusb
  Instance:                 0

bladeRF> version

  bladeRF-cli version:        1.7.0-git-6b659c2d
  libbladeRF version:         2.1.0-git-6b659c2d

  Firmware version:           2.2.0-git-3d38fac2
  FPGA version:               0.8.0
My ybts config is here:
And here the log:
« Last Edit: June 18, 2019, 02:01:19 PM by desma »


  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Phone doesn't auto connect to yatebts
« Reply #1 on: July 13, 2019, 06:31:47 PM »
Does anyone can help here? I've also bought a bladerfx40 and I'm having the same result. Any tips? Nuand forum is locked to new questions so I'm forced to ask here. Thanks in advance.

Monica Tepelus

  • Administrator
  • Full Member
  • *****
  • Posts: 192
    • View Profile
Re: Phone doesn't auto connect to yatebts
« Reply #2 on: July 15, 2019, 05:29:33 AM »
Hi Desma,

To help debug this you can use the telnet console: telnet 0 5037
To clean the logs: debug gsmtrx off. That information is not relevant  and it usually flods the logs.
Then activate better logging: debug ybts level 10, debug mbts level 9. This should show if you actually see the registration requests.

Regarding automatic registration:
- if the MCC MNC on the SIM are different than the ones configured, the phone won't try to connect automatically
- if registration was rejected (depending on the error message) the phone won't try again , you can try to remove the sim and insert in back again. But some phones might not try again. You should use a different phone/sim.
- where is the subscriber information stored: subscribers in nipc mode/ regexp/ roaming mode to a core network?

If you suspect a radio issue:


  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Phone doesn't auto connect to yatebts
« Reply #3 on: July 17, 2019, 10:19:17 AM »
Hi Monica, thank you for your kind help, the fact is that I'm working on an emergency bts, needed in such situations (disasters, earthquakes) where normal mobile operators are not all the phones in my range must connect to my bts. Is it possible?
I tried your commands..but should I start yate with:
Code: [Select]
sudo yate -vvvvv and then set the log levels in telnet right? Because I can't see that much. does the log levels must coincide with the number of -vvvvv when I start yate?