Author Topic: Help me on Mutex Problem  (Read 78 times)

ganapathi

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
Help me on Mutex Problem
« on: August 11, 2019, 06:32:56 AM »
Hi,

As i am trying to create the connection through http to SIP for webrtc connection. But while making a call , am getting this error.

<FAIL> Thread 'YSIP Worker' could not lock mutex 'SslSocket' owned by 'HTTPServer connection' waited by 0 others for 10000000 usec!

How do i solve this. help me on this.

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: Help me on Mutex Problem
« Reply #1 on: August 12, 2019, 01:50:39 AM »
Hi,

That message is telling you that someone waited 10 seconds trying to lock a mutex. That means that:
*  you may have a deadlock in your code or
* a lock() call without a pairing unlock() or
* the mutex is being held locked during an operation that takes a while

You should check the handling of that mutex (SslSocket) in your code.

ganapathi

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
Re: Help me on Mutex Problem
« Reply #2 on: August 12, 2019, 07:05:16 AM »
Thanks for the reply.

As am using httpserver module and created SSL Listener with port 2081 and using it WSS socket(wss://ip:2081) connection for webrtc over SIP.

Here SIP Registration works fine through webrtc request without any delay or issue. But issue happening only when Audio connection initiated through WebRTC.

Attached my current sip and http module file.

ysipchan.cpp- https://dpaste.de/sm0c
httpserver.cpp - https://dpaste.de/yf9T