Author Topic: Cannot connect device to BTS - Location Update Reject  (Read 472 times)


  • Newbie
  • *
  • Posts: 1
    • View Profile
Cannot connect device to BTS - Location Update Reject
« on: April 15, 2020, 10:57:48 AM »
I have yatebts set up with a bladeRF x40. I've verified that MBTS is running and have set up nipc. I registered my sim's IMSI through nipc, and I can see the BTS when a do a search of my mobile networks on my phone. When I try to connect to the BTS it returns "Unable to connect. Try later." I checked out the network traffic on Wireshark and it always gets a "Location Updating Reject" cause 12 Location Area not allowed. When I looked at the Location Area ID my MCC and MNC were set to the test network I wanted. I tried changing the MCC and MNC back to the default (001 01), and then I tried other combinations of MCCs and MNCs I found online but nothing has worked. Is there something I'm missing in the set up that other yatebts users might be familiar with that has caused similar issues in the past?