Author Topic: bladeRF rssi issues  (Read 2971 times)

tsarik

  • Newbie
  • *
  • Posts: 3
    • View Profile
bladeRF rssi issues
« on: December 30, 2014, 11:18:27 PM »
Hello,
can anyone please help with few questions:
1. network not always appear in list on phone
2. even if its appear registration can take few minutes (tested on different models)
3. why RSSI level on phone never change, it always shows same value after it registered, lets say -48 db even when i'm 30 meters away

I guess transceiver settings should be adjusted like:
MinimumRxRSSI=-63
Radio.PowerManager.MaxAttenDB=5
and something else but I have no idea about those values....

 
bladeRF firmware & FPGA used from ./mbts/TransceiverRAD1




Please, guys, any suggestions.

habibur333

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: bladeRF rssi issues
« Reply #1 on: December 31, 2014, 05:51:33 AM »
Hi Tsarik
Please mention the OS version, device model and
bladeRF> version
thanks .

tsarik

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: bladeRF rssi issues
« Reply #2 on: December 31, 2014, 08:19:44 AM »
Hi Tsarik
Please mention the OS version, device model and
bladeRF> version
thanks .

hi
ubuntu 14.04.4 x64
bladerf x115

tried both configuration:
1. lib/firmwares used from yatebts     (ibbladeRF from http://repo.yatebts.com/devel/bladeRF.tar.gz and flash the board with the firmware.img from our SVN directory mbts/TransceiverRAD1)

  bladeRF-cli version:        0.10.7-git-unknown
  libbladeRF version:         0.14.0-git-unknown

  Firmware version:           1.6.1-git-053fb13-buildomatic
  FPGA version:                 0.0.3


2. latest version, with applied patch for bladeRFDevice.cpp      http://pastebin.com/G1Y32Z9a
  bladeRF-cli version:        1.1.0-2014.12-rc1-1-ppatrusty
  libbladeRF version:         1.1.0-2014.12-rc1-1-ppatrusty

  Firmware version:           1.8.0
  FPGA version:               0.1.2

paulc

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: bladeRF rssi issues
« Reply #3 on: January 13, 2015, 01:02:25 PM »
Quote
1. network not always appear in list on phone
2. even if its appear registration can take few minutes (tested on different models)
This suggests the frequency is not calibrated. Mobile networks are very sensitive to frequency, especially when signals from several base stations can be received.
https://github.com/Nuand/kalibrate-bladeRF
http://wiki.yatebts.com/index.php/Configuration_Commands#freqcorr
http://wiki.yatebts.com/index.php/Ybts.conf#.5Btransceiver.5D_Controls_how_to_start_and_operate_the_radio_transceiver

Quote
3. why RSSI level on phone never change, it always shows same value after it registered, lets say -48 db even when i'm 30 meters away
Where and when do you see this RSSI level? Does the phone you use have some field test mode?