Author Topic: Ringback tone generate ONLY when earlymedia=false  (Read 2930 times)

tusar

  • Newbie
  • *
  • Posts: 1
    • View Profile
Ringback tone generate ONLY when earlymedia=false
« on: May 09, 2015, 01:40:21 AM »
Hi,

I am trying set early media ringback tone ONLY when earlymedia=false.

[extra]
call.ringing=80

[call.ringing]
${earlymedia}^false$=dispatch chan.masquerade;message=chan.attach;id=${id};source=tone/ring

[default]
${rtp_forward}possible=;rtp_forward=no
${formats}^\([^,]*\)=;formats=\1
.*=fork sip/sip:\0@192.168.10.5:5060;xsip_auth_bye=false;fork.calltype=persistent;fork.autoring=true;fork.automessage=call.progress

That is working fine and I am getting ringback tone. But even after answer the call, I am still getting ringback tone.

Howto stop ringback tone just after answer the call ?

Thanks in advance.


BR,
Tusar

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Ringback tone generate ONLY when earlymedia=false
« Reply #1 on: May 11, 2015, 01:01:25 AM »
Hi,
Setting the source in outgoing call leg won't work: when the call is answered the source is not replaced.
See the reply on mailing list.