Author Topic: [HELP]: Interconnecting asterisk and yate using ISUP fails  (Read 3535 times)

feredi

  • Newbie
  • *
  • Posts: 18
    • View Profile
[HELP]: Interconnecting asterisk and yate using ISUP fails
« on: March 17, 2015, 06:47:23 AM »
Hello everyone!

I am trying to connect two different boxes with a crossover cable both having Digium TE410P cards installed. Box-A is running asterisk and Box-B is running Yate. Configuration files are as below:
Box-A:
system.conf:
span=4,4,0,ccs,hdb3,crc4
mtp2=94
bchan=95-124

chan_dahdi.conf:
linkset=2
signalling=ss7
usecallerid=yes
ss7type=itu
ss7_called_nai=dynamic
ss7_calling_nai=dynamic
ss7_internationalprefix=00
ss7_nationalprefix=0
ss7_explictacm=yes
context=from-yate
switchtype=euroisdn
pointcode=2505
adjpointcode=2526
defaultdpc=2526
networkindicator=national
group=1
cicbeginswith=2
channel=95-124
sigchan=94

Box-B:
system.conf:
span=3,0,0,ccs,hdb3,crc4
dchan=63
bchan=64-93

zapcard.conf:
[span3]
type=E1
offset=62
sigchan=1
start=0
dtmfdetect=disable
voicechans=2-31
readonly=no

ysigchan.conf:
[isup_Trunk3]
enable=yes
type=ss7-isup
pointcodetype=ITU
service=5
pointcode=2526
defaultpointcode=2526
remotepointcode=2505
priority=regular
network=linkset3
lockgroup=no
earlyacm=no
sls=cic
offset=1
voice=span3
strategy=random
channelsync=1000
ringback=yes
presentation=allowed
screening=user-provided
format=alaw
print-messages=yes
slsshift = false
checklinks=true
checkfails=true

[linkset3]
enable=yes
type=ss7-mtp3
netindicator=national
netind2pctype=ITU
route=ITU,2505,0
local=ITU,2526
autostart=yes
link=link3
link3.sig=span3

[link3]
type=ss7-mtp2
autostart=yes
emergency=yes
filllink=no
rxunderrun=0
link3.sig=span3
sig=span3

Here is the output of ss7 show linkset 2 from asterisk CLI:
localhost*CLI> ss7 show linkset 2
SS7 flags: 0x0
SS7 linkset 2 status: Down
SS7 calling nai: -1
SS7 called nai: -1
SS7 nationalprefix: 0
SS7 internationalprefix: 00
SS7 unknownprefix:
SS7 networkroutedprefix:
SS7 subscriberprefix:
Switch type: ITU

SLS shift: 0
numlinks: 1
numsps: 1
  ---------------------------------
  Adjacent SP PC: 2526 STATE: DOWN
  TRA:  SENT    T19: not running T21: not running
  Routes:
    DPC       State        T6       T10
  Link ADJ_PC:SLC: 2526:0 NetMngSLS: 0
    State:      INSERVICE,  UP
    STD Test:  passed
    Got, sent :
    Inhibit:
    Changeover: NO
    Tx buffer:  0
    Tx queue:   0
    Retrans pos 0
    CO buffer:  0
    CB buffer:  0
    Last FSN:   1
    MTP3timers:

as you can see mtp2 is up but mtp3 is not and I get a lot of Got ISUP message on link while MTP3 state is not UP! in Box-A. This is really odd because running status sig linkset3 in rmanager of Yate returns:
%%+status:sig linkset3
module=sig,component=linkset3,type=ss7-mtp3;status=operational
%%-status
which means mtp3 is operational!!!

BTW, If I just replace Yate with asterisk on Box-B then ISUP will be operational and I can call each box from another!. Any idea what's causing this behavior?

UPDATE 1:
Something is looking wrong to me... I am seeing NET_MNG messages being sent from yate to asterisk having SLC=0xF and asterisk is dropping them with following message: Received message for slc 0xf, but we are 0x0. Dropping

[2] Len = 9 [ 84 ab 06 80 c9 c9 71 f2 17 ]
[2] FSN: 43 FIB 1
[2] BSN: 4 BIB 1
[2] <[2503:0] MSU
[2] [ 84 ab 06 ]
[2]     Network Indicator: 2 Priority: 0 User Part: NET_MNG (0)
[2]     [ 80 ]
[2]     OPC 2503 DPC 2505 SLS 15
[2]     [ c9 c9 71 f2 ]
[2]     H0: 7 H1: 1
[2]     Message type: TRA
[2]     [ 17 ]
« Last Edit: March 17, 2015, 09:52:25 AM by feredi »

Pavel.S

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: [HELP]: Interconnecting asterisk and yate using ISUP fails
« Reply #1 on: April 14, 2015, 02:55:48 AM »
Hi,
I solved it by disabling SLC filter in mtp3.c (libss7 2.0):

Comment  lines 1869 -  1872 in mtp3.c:
/*   if (link->slc != rl.sls) {
         ss7_error(ss7, "Received message for slc 0x%x, but we are 0x%x.  Dropping\n", rl.sls, link->slc);
         return -1;
      } */

Recompile libss7 and asterisk.

Now:

Our point code: 7
SLS shift: 0
numlinks: 1
numsps: 1
  ---------------------------------
  Adjacent SP PC: 3 STATE: UP
  TRA:  GOT SENT    T19: not running T21: not running
  Routes:
    DPC       State        T6       T10
  Link ADJ_PC:SLC: 3:0 NetMngSLS: 0
    State:      INSERVICE,  UP
    STD Test:  passed
    Got, sent :
    Inhibit:
    Changeover: NO
    Tx buffer:  0
    Tx queue:   0
    Retrans pos 0
    CO buffer:  0
    CB buffer:  0
    Last FSN:   14
    MTP3timers: