Author Topic: Callto protocol not working from browsers  (Read 8459 times)


  • Newbie
  • *
  • Posts: 1
    • View Profile
Callto protocol not working from browsers
« on: May 13, 2015, 11:31:17 AM »
Hello Guys

I have been struggling to get Yate to open and dial when I click on a callto link in my browser.

I have set the registry under HKCR with key structure tel/shell/open/command with the tel having Default-URL: tel Protocol and URL Protocol = empty data field. The command contains default - "C:\Program Files (x86)\Yate\yate-qt4.exe" -n yate-qt4 -w "C:\Program Files (x86)\Yate"%1"

I've tried to set the regitsry to URL: callto protocol, and just callto, nothing worked. I tried the command without the inverted commas, and I've tried the command with just the first part of the path up to the .exe. Still did not work.

I loaded another softphone that does popup when clicking on the callto link (x-Lite) and tried stealing all its registry entries for the callto protocol. This did not work either.

I do not have a TEL protocol in default program association so could not use this path.
I tried firefox which giver the option to select the program but still did not open Yate.
I tried on Chrome and still nothing.
I tried on Maxthon browser still nothing.
(I won't even try Internet explorer!!!!)

I really need this to work because I will use Yate in conjunction with my Hosted CRM, and the callto function will be fantastic. I really like this app and do not want to use the others.

Can someone Pleeeeease help me with this