Author Topic: enable H264 video support in YATE  (Read 7500 times)

roy

  • Newbie
  • *
  • Posts: 7
    • View Profile
enable H264 video support in YATE
« on: November 05, 2012, 05:58:12 PM »
Hi,
I am trying to get video calls with YATE and still faild to get it up.
Does anybody done this before.

Currently I can make voice call using Yate. I use the latest YATE release 4.2.0.2

Now I want to make SIP video call using YATE . I could not find any information regarding that.
Client is sending H264 codec.

This is the information :

1. All setup is inside the LAN.
2. Running YATE 4.2 on Cent OS 6.2
3. Using Jitsi Client on 2 machines in the same LAN.
4. Both clients can register and can place voice calls.
5. when I try to establish the video call it does not.
6. Codec is H264 and I have set the 
        h263-1998/90000=yes
       h264/90000=yes

      h263-1998=yes
      h263=yes
     h264=yes

in ysipchan.conf

Please advice me how to configure YATE for SIP video call.
Regards,
Roy.

cc08

  • Guest
Re: enable H264 video support in YATE
« Reply #1 on: November 05, 2012, 11:29:54 PM »
Hi, roy!

From my experiments with video calls, I have concluded that the YATE did not properly handle dynamic types rtpmaps. But my message to the mailing list, no response. So that is a sore subject for a long time, I think ...

Best regards,
cc08.

ps. sorry my english.

Diana Cionoiu

  • Administrator
  • Jr. Member
  • *****
  • Posts: 71
    • View Profile
Re: enable H264 video support in YATE
« Reply #2 on: November 06, 2012, 01:45:01 PM »
Hello Roy,

Can you please post also a capture of SIP packets?

From both sides and explain a bit what you do?

Like you call from IP1 to Yate to IP2. Please capture both sides of the conversation. Use the attach functionality of the forum to add the captured file with wireshark.

Diana

P.S. cc08, I didn't had time to answer to your stuff and there weren't enough informations in the e-mail you've sent on the mail list.

roy

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: enable H264 video support in YATE
« Reply #3 on: November 08, 2012, 01:01:18 AM »
Hi Diana,
Thanks for your reply.

Well This is my setup

My Yate server is on IP 192.168.1.20 CentOS 6.3 server. Firewall is off (iptables/ip6tables)
I have Jitsi's running on 192.168.1.50 (acc 1002) and 192.168.1.58 (acc 1004)
Both registered successfully.
Possible to do voice call in both ways and works very well.

I called from Jitsi client 1002 on 192.168.1.50 to Jitsi client on 192.168.1.58 and tried to toggle the video option.

When I try to make the video call it fails.

I go the siptrace from wireshark from client side and also siptrace log from Yate with tcpdump  and debug log with l option at the start.
Please find the attached files.

Please help me out on this issue.

Best Regards,
Roy.

virrus

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: enable H264 video support in YATE
« Reply #4 on: November 12, 2012, 01:50:55 AM »
First of all, video calls are always possible when using rtp_forward and sdp_forward.
When rtp stream is going through yate, some problems may arise.
From my experience, problems with video calls are usually caused by missing fmtp: lines in sdp.
Yate reproduces only a few fmtp parameters on outgoing call leg, and most video phones can't live without those parameters.
You can try this patch to fix this issue: http://vir.lclt.ru/yate/sdp-fmtp.diff
It worked for me a couple of years ago, hope it still works :)

roy

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: enable H264 video support in YATE
« Reply #5 on: November 12, 2012, 03:18:59 AM »
Hi,
Thanks a lot for your reply.
I will apply this fix and check it and let you know. Thanks again for the reply.

Best Regards,
Roy

roy

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: enable H264 video support in YATE
« Reply #6 on: December 27, 2012, 06:25:46 PM »
Hi cc08,

Thanks for the patch file. I applied it but it did not help. Still the same issue.
Still waiting for an answer from the YATE team.

Best Regards,
Roy.