Author Topic: Yate and YateBTS install problems  (Read 1766 times)


  • Newbie
  • *
  • Posts: 2
    • View Profile
Yate and YateBTS install problems
« on: September 22, 2017, 03:19:40 PM »

The installation for both Yate and Yate BTS is somehow not working on All Linux flavors,

my system is Kali rolling and I Tried installing Yate but I got an OpenSSL error AES_ctr128_encrypt not declared and i google and looked around for a while and someone in a github discussion mentioned it's a problem with Kali but I looked further and found out that OpenSSL no longer has that function in aes.h, so why is yate still using it? what should I do to get that part working?

Anyway, I tried to circumvent that problem with the --without-openssl=no parameter passed to configure.
After successfully compiling it I tried compiling YateBTS but it just gives an error without an indication of what is wrong. besides me, it seems some other people are having the same problem with it here

I would appreciate any help about this issue, those people who purchased bladerf spend quite a lot of money and it's really a bummer not to be able to get yate working.

has anyone else ran into this problem?