Author Topic: Eliza SMS Issue - No Response  (Read 4723 times)

SugarCakes

  • Newbie
  • *
  • Posts: 14
    • View Profile
Eliza SMS Issue - No Response
« on: August 29, 2015, 01:49:46 PM »
Hi,

Just setup yateBTS, all going ok so far (on the whole).
  • I can make cell to cell calls.
  • Both cells can exchange SMS.
  • Both cells can call David.

Issues:
  • No one can text Eliza.....
    Error attached in screenshot, but message is Droped sms from imsi nib_smsc to number 117752717.
  • The GPRS seems very intermittent.

Would appreciate help, especially with SMS issue.

Cheers!
Eski

SugarCakes

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #1 on: August 29, 2015, 01:56:08 PM »
Can't seem to attach log so here goes:
Primitive: ConnRelease
Info: 0
Connection: 5
-----
DATE: <ybts:INFO> MT SMS 'ybts/sms/1' to (some hex) TMSI=007b0001 IMSI= $
DATE <nib:INFO> Could not deliver sms from imsi nib_smsc to number 117752717
DATE <ybts:INFO> MT SMS 'ybts/sms/2 to (some hex) TMSI=007b0001 IMSI=
DATE <ybts-signalling:INFO> Sending [0x2654a30]
----
Primitive: EstablishSAPI
Info: 3
Connection :4
----
DATE: <ybts:INFO> MT SMS 'ybts/sms/2' to (some hex) TMSI=007b0001 IMSI= $
DATE <nib:INFO> Could not deliver sms from imsi nib_smsc to number 117752717
DATE <ybts:INFO> MT SMS 'ybts/sms/3 to (some hex) TMSI=007b0001 IMSI=
DATE <ybts-signalling:INFO> Sending [0x2654a30]

One other thing is a message which I can't quite remember but something along the lines of " failure = postDelayDial"

UPDATE: Eliza responded once, but it looks like a one off :S
GPRS is more stable when I edited the N210 rxgain to something higher around 25, to make the noise closer to -68/-70
« Last Edit: August 30, 2015, 04:32:41 PM by SugarCakes »

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #2 on: August 31, 2015, 01:18:11 AM »
A full log with SMS deliver would help.
Please don't replace the debug time. I don't think it's showing some private data and might help debugging (it may show intervals between events). If you want to hide the date just start yate with -Dt command line option: it will show the time from program start.

SugarCakes

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #3 on: August 31, 2015, 07:16:12 AM »
I can't seem to add attachments so here is a link to the log:

http://pastebin.com/WEMTb7eu

In the log you can see the cell successfully auths to the BTS
A GPRS exchange occurs.
An SMS is sent to Eliza and a response is received.
A 2nd SMS is sent to Eliza and this fails.

Also I typed the previous message which is why I omitted the date :) nothing intentional, just saving time!

Many thanks!

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #4 on: August 31, 2015, 08:15:57 AM »
There might be a bug in ybts.
It may be related to the situation when the phone looses the radio channel very soon after requesting the service and starts another one.
This will be investigated.

Is this happening repeatedly?
Can you tell what phone (manufacturer and model) are you using?

SugarCakes

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #5 on: August 31, 2015, 08:23:18 AM »
Hi Marian

Thank you for your quick reply :)
Yes this happens repeatedly and with different phone types.

Currently tested with iPhone 4/5s/6, nokia 3310 and Blackberry 8310 and Q10.

Thank you for investigating!
Hope you don't mind me raising all these issues, I would help fix if I could debug the code.

Unrelated, if it is fixed I don't think I can upgrade because yatebts no longer works with Ettus equipment :( are there any plans to let it work again like it used too?http://forum.yate.ro/index.php?topic=495.0

Thanks!

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #6 on: August 31, 2015, 08:41:09 AM »
We don't mind about users raising issues.
They might hit bugs!!!

I don't know if there is any plan for other hardware support.

SugarCakes

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #7 on: August 31, 2015, 08:53:26 AM »
No problem!

It's a small shame, because the software works really well with Ettus kit using the Transceiver in the old package! (Just sad I can't update the software now)

I might look at buying a blade-rf though if some of the bugs get ironed out :)
Some big plans for the kit!

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #8 on: September 01, 2015, 06:12:24 AM »
I have some problems identifying the module failing to handle the failure scenario you raised.
Would you be available to repeat the test with more debug?
This would include:
- configure gsm/gprs tapping
- running Wireshark and post the capture (which would include GSM layer 2 packets)

Thank You!

diabolo

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #9 on: September 28, 2015, 11:12:03 PM »
Any luck with sorting this out? I'm having the same problem.

Calls to David work
SMS between phones work
Calls between phones work

SMS to Eliza gets an initial response, but no subsequent responses.

Log shows:
Code: [Select]
2015-09-29_00:50:22.000789 <ybts-signalling:ALL> Removing released connection 10 [0x7f94ec035e60]
2015-09-29_00:50:25.721951 <ybts:INFO> MT SMS 'ybts/sms/17' to (0x256b630) TMSI=007b0001 IMSI= failed reason='postdialdelay' RPDU=
2015-09-29_00:50:25.722624 <nib:INFO> Could not deliver sms from imsi nib_smsc to number 326624311.
2015-09-29_00:50:25.725186 <ybts:INFO> MT SMS 'ybts/sms/18' to (0x256b630) TMSI=007b0001 IMSI=
2015-09-29_00:50:25.726627 <ybts-signalling:INFO> Sending [0x7f94ec035e60]

Any suggestions?

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #10 on: September 30, 2015, 12:38:17 AM »
I have an idea but I can't check it: I can't duplicate your issue.
Can you help me?
If you are available for that, please see my previous post.

diabolo

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #11 on: October 02, 2015, 03:47:02 PM »
Can you walk me through how to:

- configure gsm/gprs tapping
- running Wireshark and post the capture (which would include GSM layer 2 packets)

thanks!

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #12 on: October 05, 2015, 01:21:48 AM »
Enable GSM tap:
ybts.conf:
[tapping]
GSM=yes
TargetIP=the_ip_of_wireshark

Wireshark may be ran locally (TargetIP=127.0.0.1)

Run Wireshark. Filter on (udp.port == 4729). This is the port where GSM layer 2 packets will be sent.
Run YateBTS. Wait for SMS failure (and about 1 minute after that).
Post yate log and Wireshark capture.

If you need some assistance in setting up Wireshark and/or exporting capture just tell me!!!

Thank You!!!

diabolo

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #13 on: October 09, 2015, 02:56:17 AM »
Thanks for your response!

Haven't yet had a chance to run that test (and will do so when I get back to the lab next week - I'm currently traveling).

But I was able to do a clean install of YateBTS and BladeRF, and after adjusting min MinAttenDB and MaxAttenDB a bit I was able to get noise within +/- 3 dB of target -55 dB.

Works just fine now.

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: Eliza SMS Issue - No Response
« Reply #14 on: October 09, 2015, 04:14:22 AM »
That's good to hear.
It would wonderful if you are available to test it anyway with old setup.
Just to have a log and capture with failure scenario.