Author Topic: GPRS problem in YateBTS  (Read 4896 times)

pfour

  • Newbie
  • *
  • Posts: 3
    • View Profile
GPRS problem in YateBTS
« on: August 11, 2014, 01:44:50 AM »
My cellphone can successfully registered in YateBTS. Voice call and SMS are both OK. But GPRS service has problem.

I read the GPRS throubleshooting page. http://wiki.yatebts.com/index.php/GPRS_Troubleshooting

My cellphone status is:
1) It got IP address 192.168.99.1.
2) I ran “tcpdump -nn -i sgsntun”. There is only uplink traffic, no downlink traffic.
3) I tried to "ping 192.168.99.1" from PC side. There is no response. And the yate.log output is:
<mbts:MILD> miniggsn.cpp:441:miniggsn_snd_npdu_by_mgc: ggsn: Packet failed test, discarded: (packet_dest_ip_addr & rp->ipMasknl) != (rp->ipBasenl & rp->ipMasknl)

What configuration is wrong? What configuration is wrong? NAT problem? How should I configure it?

Thanks
Pfour

pfour

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: GPRS problem in YateBTS
« Reply #1 on: August 11, 2014, 04:23:30 AM »
It works now. I used the iptables.rules in OpenBTS

https://wush.net/trac/rangepublic/wiki/GPRS

although I'm still not very clear about the NAT configuration.

pfour

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: GPRS problem in YateBTS
« Reply #2 on: August 11, 2014, 04:39:46 AM »
Another question: if the cellphone didn't get IP address, what should we do?

I added the second cellphone into the yatebts. This cellphone didn't get ip address.

MS#2,TLLI=8004a002,c0022002 rrmode=PacketIdle Bytes:71up/33down Utilization=0%
    GMM Context: imsi=xxxxxxxxxxxxxxxx ptmsi=0x22002 tlli=0xc0022002 state=GmmRegisteredNormal age=85 idle=85 IPs=none

david.burgess

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: GPRS problem in YateBTS
« Reply #3 on: August 28, 2014, 07:46:36 PM »
Be sure the phone has a defined access point name (APN).  It does not matter what the APN is, as long as it exists.

yateuser

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GPRS problem in YateBTS
« Reply #4 on: August 09, 2018, 04:32:25 AM »
pfour:  Could you share your config with me.  I have a routing error and my phones don't connect once I have GRPS enabled.