Author Topic: transcoding from A-law to u-law not working  (Read 3923 times)

m.savelsberg

  • Newbie
  • *
  • Posts: 4
    • View Profile
transcoding from A-law to u-law not working
« on: November 22, 2012, 01:41:29 PM »
Hello,

using Yate 4.2.0 2
mandriva kernel (version 2.6.33.7-server-2mnb)

registered customer is using codec g711 alaw for making calls. We want Yate to transcode this to g711 ulaw for outgoing calls

We added the following lines to regexroute.conf

[default]
${rtp_forward}possible=;rtp_forward=yes
${rtp_forward}^yes$^=;formats=${oformats}
${formats}^=;formats=mulaw

The problem is that transcoding is not working, as calls going out of Yate are still with g711 alaw

In yate log I see "  'alaw' -> [0x7fa250019150] 'alaw' succeeded  "

in the attachment I added the complete log of a call attempt.

Any idea what I'm missing in the config ?

Thanks in advance
Martin Savelsberg

Diana Cionoiu

  • Administrator
  • Jr. Member
  • *****
  • Posts: 71
    • View Profile
Re: transcoding from A-law to u-law not working
« Reply #1 on: November 22, 2012, 06:20:10 PM »
Edit ysipchan.conf and add additional codecs and modify formats parameter.

m.savelsberg

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: transcoding from A-law to u-law not working
« Reply #2 on: November 23, 2012, 04:14:38 AM »
I made the following changes in ysipchan.conf but withouth sucess

[codecs]
default=disable

;mulaw=default
mulaw=enable

;alaw=default
alaw=enable

1xx_change_formats=yes


Any idea what is wrong?

Thanks in advance,
Martin Savelsberg

asymetrixs

  • Administrator
  • Newbie
  • *****
  • Posts: 47
    • View Profile
Re: transcoding from A-law to u-law not working
« Reply #3 on: November 23, 2012, 06:54:33 AM »
You are trying to forward RTP and to transcode? Is this even possible?
I guess yate has to handle the RTP to make transcoding, because that is where the voice data is in.
If you set rtp_forward to 'yes', then the two endpoints (the one sending SIP to you and the one you are sending SIP to) handle RTP directly without your interaction and then transcoding is impossible to happen in your system.

Try it with

[default]
rtp_forward=no
format=mulaw
formats=mulaw

vankooch

  • Administrator
  • Newbie
  • *****
  • Posts: 49
    • View Profile
Re: transcoding from A-law to u-law not working
« Reply #4 on: November 23, 2012, 08:25:09 PM »
well I'm not sure, but you should put format(s) and other parameters to a rule like, I'm not sure if processes them global

^12234$=sip/sip:\1@IP;rtp_forward=no;format=mulaw;formats=mulaw