Author Topic: CallerID setup  (Read 2527 times)

djBo

  • Newbie
  • *
  • Posts: 2
    • View Profile
CallerID setup
« on: January 05, 2015, 12:43:07 PM »
Dear list,

I could be doing it wrong!

I've installed yate on my domain's main server (ubuntu, apt-get install yate) and added a couple of accounts in regfile.conf. Installed the accounts on several Android devices using the native SIP application (Android 4.4.2+). Within minutes I was making calls!

My question:
I am making a call from one device to another using "username@domainname". When I look at the device with the incoming call it says "username@domainIPaddress".

What changes do I have to make to the yate configuration, to make the incoming call show up as "username@doimainname"?

With kind regards,
Rory

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: CallerID setup
« Reply #1 on: January 06, 2015, 02:16:05 AM »
Edit regexroute.conf.
Change the following:

[extra]
call.execute=30

[call.execute]
${domain}^$=;domain=YOUR_DOMAIN_NAME

NOTE: This will affect all outgoing calls. I suppose for your scenario it will do the job.

djBo

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: CallerID setup
« Reply #2 on: January 06, 2015, 11:54:55 AM »
Thanks! Works like a charm  :)

NOTE: This will affect all outgoing calls. I suppose for your scenario it will do the job.

Just for arguments sake: the "domain" field contains the ip-address of the server hosting yate?

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: CallerID setup
« Reply #3 on: January 07, 2015, 01:22:15 AM »
You can put in the domain parameter the value you want to be set in the domain part of the SIP 'From' header URI.
The string your are setting there is what you want to be.
If you are not setting it yate will build the 'From' header from transport local ip address.

asymetrixs

  • Administrator
  • Newbie
  • *****
  • Posts: 47
    • View Profile
Re: CallerID setup
« Reply #4 on: January 15, 2015, 04:12:06 AM »
Just out of curiosity:
Which yate version did you install?
I think the ubuntu sources do not provide the latest yate version.

You can find updated packages here: https://launchpad.net/~sico/+archive/ubuntu/yate