Author Topic: YATE setup according to OSTN standard hangs up  (Read 1927 times)

agent725

  • Newbie
  • *
  • Posts: 1
    • View Profile
YATE setup according to OSTN standard hangs up
« on: January 19, 2015, 07:34:31 AM »
Hi Yate enthousiasts,

Recently I have entered the world of PBX, and have tried out many different software solutions (Asterisk, Freeswitch, SIP Witch), but I have come to the conclusion I like Yate best. :)

So I quickly set up an OSTN compliant server. Everything is configured according to the standard, and Yate Client, Jitsi, Blink and CSipSimple can all register and make calls over TLS and SRTP.

But here comes the problem:  (drum roll)
 Every time I call using Yate, I can only do so for 15 seconds. Audio both ways is working fine, and I am traversing two NAT setups (client-side) succesfully via the server.

When the call originates from Yate Client, the call stays open (as it should), but when I call from another VOIP client (Blink,Jitsi, or CSipSimple) the call is hung up after 15 seconds.

First I looked around to see if this problem was already solved. I stumbled upon    Topic: Life without UDP 5060, and tried many different variations of this. It didn't work.

The problem is only prevalent with a secure OSTN compliant setup. I have been trying to solve the hangup problem for two days now, but cannot figure out what it is.  :o

Would someone here know the answer? Is this a bug in Yate?

Some people would say: use FreeSwitch. But the simple transparency of Yate is something I have grown to love. So I'd rather stick with Yate, but would like to use it for secure communications. :)

Best regards,
Agent725

marian

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: YATE setup according to OSTN standard hangs up
« Reply #1 on: January 20, 2015, 03:07:05 AM »
Your issue may be the same as the ones listed below:

See: http://forum.yate.ro/index.php?topic=323

See also the thread at:
http://yate.null.ro/archive/?action=show_msg&actionargs%5B%5D=90&actionargs%5B%5D=90

You should post a yate log to make sure.