Author Topic: Could not route call to '32843' [solved]  (Read 6405 times)

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Could not route call to '32843' [solved]
« on: May 09, 2015, 06:30:27 AM »
Hello,
I've installed all and yatebts works fine with bladeRF40
but when I try to make a IRV call to 32843 this is the result:

Could not classify call from 'TMSI007b0001', wasted 17 usec
2015-05-09_14:16:01.686657 <nib:INFO> onRoute TMSI007b0001 -> 32843
2015-05-09_14:16:01.688820 <INFO> Could not route call to '32843' in context 'default', wasted 477 usec
2015-05-09_14:16:01.689020 <ybts/1:MILD> Call rejected error='noroute' reason='No route to call target
.....

    <Cause coding="GSM-PLMN" location="LPN">noroute</Cause>
  </Message>
</CC>
-----
2015-05-09_14:16:01.690285 <ybts/1:CALL> Hangup reason='noroute' [0xb6201bb0]

and
when I run yate -sD -vvvvv -l /usr/src/yate/logfiles/yate.log
I get these errors:
.....
2015-05-09_14:15:32.470775 <mbts:MILD> miniggsn.cpp:493:miniggsn_init: could not open GGSN.Logfile.Name log file:ggsn.log
2015-05-09_14:15:32.722404 <mbts:MILD> iputils.cpp:456:ip_finddns: GGSN: DNS servers: 127.0.1.1 0.0.0.0
2015-05-09_14:15:32.723053 <mbts:MILD> iputils.cpp:363:setprocoption: Can not open file /proc/sys/net/ipv4/ip_forward error: Permission denied
2015-05-09_14:15:32.723449 <mbts:MILD> iputils.cpp:363:setprocoption: Can not open file /proc/sys/net/ipv4/ip_nonlocal_bind error: Permission denied
2015-05-09_14:15:32.724141 <mbts:MILD> iputils.cpp:311:ip_tun_open: could not create tunnel sgsntun: ioctl error: Operation not permitted
2015-05-09_14:15:32.724219 <mbts:MILD> miniggsn.cpp:627:miniggsn_init: ggsn: ERROR: Could not open tun device sgsntun
2015-05-09_14:15:32.724548 <mbts:MILD> MAC.cpp:888:macStart:   14:15:32.7,0:GGSN failed to init
....

Anyone can help me to solve this?
thanks



« Last Edit: May 23, 2015, 01:21:53 AM by andrew77 »

marian

  • Hero Member
  • *****
  • Posts: 505
    • View Profile
Re: Could not route call to '32843'
« Reply #1 on: May 11, 2015, 01:02:43 AM »
Hi,
Check if you have a route to called number (32843).

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
Re: Could not route call to '32843'
« Reply #2 on: May 11, 2015, 01:31:36 AM »
Hi,

Please make sure that in javascript.conf you have this:

[general]
routing=welcome.js





andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Could not route call to '32843'
« Reply #3 on: May 12, 2015, 12:00:00 PM »
Yes,

I have this:

[general]
routing=welcome.js

my sim card is registered to a true provider,
with yatebts I connect in "Roaming"

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
Re: Could not route call to '32843'
« Reply #4 on: May 13, 2015, 01:22:57 AM »
Regarding the "permission denied" messages, please make sure to run yate as root.

What do you mean by
Quote
with yatebts I connect in "Roaming"
?

YateBTS has 2 modes: NIB or Roaming. You can't run YateBTS in both modes at the same time. In  NIB mode you can call, if everything is configured correctly, the IVR available at 32843.
Please look throuhg the documentation available here
http://wiki.yatebts.com/index.php/Javascript_Roaming
http://wiki.yatebts.com/index.php/Javascript_NIB

Also, make sure you are loading the correct configuration. You can check that by running the
'status engine'
command in the telnet console (look for the configpath value).

If still that doesn't work, please attach a log and your configuration.

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Could not route call to '32843'
« Reply #5 on: May 16, 2015, 02:22:31 AM »
As I start Yatebts I get this:


Release 4.0.3 formal build date Apr 12 2015 rev475
20150516081820.275312 <mbts:NOTE> GSMConfig.cpp:80:regenerateBeacon: regenerating system information messages, changemark 1
Starting MBTS...
20150516081820.275861 <ybts-signalling:INFO> Received [0x145f700]
-----
Primitive: Handshake
Info: 0
-----
20150516081820.275971 <ybts:NOTE> State changed WaitHandshake -> Running
20150516081820.276026 <ybts-signalling:INFO> Sending [0x145f700]
-----
Primitive: Handshake
Info: 0
-----
20150516081820.927425 <javascript:INFO> Parsed 'nib' script: /usr/local/share/yate/scripts/nib.js
20150516081820.932864 <nib:CONF> Please configure country code. See subscribers.conf or use the NIB web interface
20150516081820.937727 <nib:INFO> Finished reading saved registered subscribers. Found 2 registered_subscribers.
20150516081820.938598 <nib:INFO> Checked that only NIB is enabled.
20150516081820.938757 <ALL> Rescanning handler list for 'engine.start' [0x7ffd5d425710] at priority 100
Yate engine is initialized and starting up on andsim-HP-Pavilion-15-Notebook-PC
20150516081820.938925 <INFO> Creating first message dispatching thread
20150516081821.098638 <cpuload:NOTE> Updating CPU core number from 1 to 4
20150516081821.277291 <mbts:MILD> TRXManager.cpp:283:sendCommandPacket: TRX link timeout on attempt 1
20150516081822.278532 <mbts:MILD> TRXManager.cpp:283:sendCommandPacket: TRX link timeout on attempt 2
20150516081823.279015 <mbts:MILD> TRXManager.cpp:283:sendCommandPacket: TRX link timeout on attempt 3
20150516081824.280483 <mbts:MILD> TRXManager.cpp:283:sendCommandPacket: TRX link timeout on attempt 4
20150516081825.281344 <mbts:MILD> TRXManager.cpp:283:sendCommandPacket: TRX link timeout on attempt 5
ALERT 139880744073088 10:18:25.2 TRXManager.cpp:432:powerOff: POWEROFF failed with status -120150516081825.281488 <mbts:NOTE> TRXManager.cpp:293:sendCommandPacket: lost control link to transceiver

20150516081825.281593 <mbts:WARN> TRXManager.cpp:432:powerOff: POWEROFF failed with status -1
20150516081825.416484 <mbts:NOTE> OpenBTS.cpp:145:startTransceiver: starting transceiver ./transceiver-bladerf w/ 1 ARFCNs and Args:
20150516081825.574908 <transceiver:NOTE> bladeRFDevice.cpp:110:open: Opened bladeRF serial=c36781bf545973547fdfed05e6edd3a7 firmware version 1.8.0 (1.8.0)
20150516081825.775101 <transceiver:NOTE> Transceiver.cpp:68:Transceiver: running 1 ARFCNs with oversampling 4
Starting transceiver
20150516081830.307261 <transceiver:NOTE> bladeRFDevice.cpp:243:start: starting bladeRF in super speed mode...
20150516081830.309895 <transceiver:NOTE> bladeRFDevice.cpp:486:readSamples: RX Timestamp adjusted by 1 to 2
20150516081830.319226 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T1
20150516081830.320215 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T2
20150516081830.321375 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T3
20150516081830.322358 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T4
20150516081830.323618 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T5
20150516081830.324670 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T6
20150516081830.325814 <mbts:NOTE> GSMConfig.cpp:532:createCombinationI: Configuring combination I on C0T7
20150516081830.328188 <mbts:MILD> miniggsn.cpp:493:miniggsn_init: could not open GGSN.Logfile.Name log file:ggsn.log
20150516081830.328344 <mbts:MILD> iputils.cpp:456:ip_finddns: GGSN: DNS servers: 8.8.8.8 8.8.4.4
20150516081830.328422 <mbts:MILD> iputils.cpp:363:setprocoption: Can not open file /proc/sys/net/ipv4/ip_forward error: Permission denied
20150516081830.328481 <mbts:MILD> iputils.cpp:363:setprocoption: Can not open file /proc/sys/net/ipv4/ip_nonlocal_bind error: Permission denied
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
MBTS ready
20150516081830.833991 <ybts-signalling:INFO> Received [0x145f700]
-----
Primitive: RadioReady
Info: 0
-----
20150516081830.834230 <ybts:NOTE> State changed Running -> RadioUp

and "status engine" gives me:

status engine
%%+status:engine
name=engine,type=system,version=5.4.3,revision=5966,nodename=andsim-HP-Pavilion-15-Notebook-PC;plugins=68,inuse=1,handlers=519,hooks=2,messages=0,supervised=false,runattempt=0,lastsignal=0,threads=28,workers=1,mutexes=247,semaphores=0,acceptcalls=accept,congestion=0;sharedpath=/usr/local/share/yate,configpath=/usr/local/etc/yate,usercfgpath=/home/andsim/.yate,modulepath=/usr/local/lib/yate,workpath=/home/andsim
%%-status

even running yatebts as root the result is the same: no route to call...
thanks

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
Re: Could not route call to '32843'
« Reply #6 on: May 18, 2015, 06:38:06 AM »
Please post the log corresponding with the call attempt. Please activate message sniffer also ( see http://docs.yate.ro/wiki/Debugging_and,_or_Investigation_of_messages ) in order to be able to see through which handlers the call.route message went through.

Also, please state which version of Yate & YateBTS are you using. How are you starting Yate?

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Could not route call to '32843'
« Reply #7 on: May 18, 2015, 12:34:31 PM »
I run:
yate -Df -vvvvv -l /var/log/yate.log

the version is:

/usr/local/bin/yate-config --version
5.4.3
in:
which -a yate-config
/usr/local/bin/yate-config

Connected to 127.0.0.1.
Escape character is '^]'.
YATE 5.4.3-devel1 r5966 (http://YATE.null.ro) ready on andsim-HP-Pavilion-15-Notebook-PC.
debug on
Debug level: 10, objects: off, local: on, threshold: 10
color on
Colorized output: yes
sniffer on
Returned true 'engine.command' delay=0.000113
  thread=0x7f2dcc000990 'RManager Connection'
  data=(nil)
  retval='Message sniffer: on, timer: off
'
  param['line'] = 'sniffer on'
  param['cmd_address'] = '127.0.0.1:53196'
  param['cmd_machine'] = 'false'
  param['cmd_width'] = '80'
  param['cmd_heigth'] = '24'
Message sniffer: on, timer: off
Sniffed 'idle.execute' time=1431970895.908003
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
Returned false 'idle.execute' delay=0.003696
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
  param['handlers'] = 'javascript:110'
Sniffed 'idle.execute' time=1431970900.923399
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
Returned false 'idle.execute' delay=0.004362
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
  param['handlers'] = 'javascript:110'
Sniffed 'idle.execute' time=1431970905.935216
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
Returned false 'idle.execute' delay=0.004317
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
  param['handlers'] = 'javascript:110'
Sniffed 'idle.execute' time=1431970910.950600
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
Returned false 'idle.execute' delay=0.005848
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
  param['handlers'] = 'javascript:110'
Sniffed 'idle.execute' time=1431970915.964143
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
Returned false 'idle.execute' delay=0.000920
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
  param['handlers'] = 'javascript:110'
Sniffed 'idle.execute' time=1431970920.973844
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
Returned false 'idle.execute' delay=0.005899
  thread=0xf74170 'Engine Worker'
  data=(nil)
  retval='(null)'
  param['module'] = 'nib_cache'
  param['handlers'] = 'javascript:110'

20150518174414.335349 <nib:INFO> onRoute TMSI007b0001 -> 32843
20150518174414.337420 <INFO> Could not route call to '32843' in context 'default', wasted 437 usec
Returned false 'call.route' delay=1.205261
  thread=0x7f2de8004ce0 'Call Router'
  data=(nil)
  retval='(null)'
  param['id'] = 'ybts/1'
  param['module'] = 'ybts'
  param['status'] = 'incoming'
  param['address'] = 'TMSI007b0001'
  param['billid'] = '1431970838-1'
  param['answered'] = 'false'
  param['direction'] = 'incoming'
  param['phy_info'] = 'TA=3 TE=-0.566 UpRSSI=1 TxPwr=30 DnRSSIdBm=-111 time=1431971052.094'
  param['caller'] = '1408089'
  param['imsi'] = '222881661408089'
  param['tmsi'] = '007b0001'
  param['imei'] = '351815050022810'
  param['called'] = '32843'
  param['callednumtype'] = 'unknown'
  param['callednumplan'] = 'isdn'
  param['username'] = '222881661408089'
  param['imei'] = '351815050022810'
  param['emergency'] = 'false'
  param['privacy'] = 'false'
  param['handlers'] = 'javascript:15,regexroute:100,javascript:15,cdrbuild:50,javascript:80,fileinfo:90,subscription:100,sip:100,jingle:100,iax:100,sig:100,analog:100,regfile:100,regexroute:100'
20150518174414.338370 <ybts/1:MILD> Call rejected error='noroute' reason='No route to call target' [0x7f2de8003290]
20150518174414.338508 <ybts/1:INFO> Call 'i0' changed state CallProceeding -> Release [0x7f2de8003290]
20150518174414.338771 <ybts-signalling:INFO> Sending [0x11748b0]
-----
Primitive: L3Message
Info: 0
Connection: 2

<CC>
  <TID TIFlag="true">0</TID>
  <Message type="Release">
    <Cause coding="GSM-PLMN" location="LPN">noroute</Cause>
  </Message>
</CC>
-----


Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
Re: Could not route call to '32843'
« Reply #8 on: May 19, 2015, 02:32:31 AM »
Could you also post javascript.conf and yatebts.conf (the whole files) from your configuration path (which yate says it's configpath=/usr/local/etc/yate).

Also, post a full log, not a piece of it (if it's too long, you can attach it).

I still suspect a misconfiguration issue.
« Last Edit: May 19, 2015, 02:34:40 AM by oana »

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Could not route call to '32843'
« Reply #9 on: May 19, 2015, 02:27:43 PM »
it is not possible to give you the whole telnel log because terminal cuts the starting lines when they are a lot!

thanks!

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
Re: Could not route call to '32843'
« Reply #10 on: May 20, 2015, 01:52:18 AM »
Regarding this:

Quote
it is not possible to give you the whole telnel log because terminal cuts the starting lines when they are a lot!

you said that you are starting Yate like this: yate -Df -vvvvv -l /var/log/yate.log. So you have logging to file activated to file yate.log in /var/log. You could have attached that (or the part of if that corresponds with the call). It's not needed anymore, but for future reference.

You said that you had configured in javascript.conf ;
Code: [Select]
[general]
routing=welcome.js

but looking at your attached javascript.conf, i see:

Code: [Select]
[general]
; General settings for the Javascript module

; scripts_dir: string: The absolute or relative path used by default to load
;  scripts if no full path is specified
;scripts_dir=${sharedpath}/scripts

; include_dir: string: The absolute or relative path used when including other
;  files via #include or #require if no full path is specified
; If the file is not found in include_dir it will be searched in scripts_dir
;include_dir=${configpath}

; routing: string: Name of the file holding the routing instructions
; Example: routing=route.js
;routing=


So you've either not attached the correct javascript.conf or the one where you've told me you made the configuration is not in the configuration path of yate.

So I will repeat this again: check that in  the javascript.conf located in the configuration path of yate (path reported by yate in configpath when you give the command status engine in telnet. The last status engine you posted said that the path is configpath=/usr/local/etc/yate, but check again) you have configured

Code: [Select]
routing=welcome.js
If after that, it still doesn't work, paste again: yate log with sniffer enabled, output of status engine, and ybts.conf and javascript.conf from the configuration path reported by yate.

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Could not route call to '32843'
« Reply #11 on: May 20, 2015, 02:26:04 PM »
Ok,
I set up routing:welcome.js  (without ";" ) and routing is OK!
but I don't hear anything, I have this error:

<WARN> DataTranslator::attachChain [0x7fe8340052b0] 'mulaw' -> [0x7fe834006f60] 'gsm' failed


According
http://wiki.yatebts.com/index.php/You_don't_hear_anything
Should I reinstall yate and Yatebts? I have libgsm1-dev installed (from synaptic pack manager, after having installed yate and yatebts) 

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
Re: Could not route call to '32843'
« Reply #12 on: May 21, 2015, 01:36:09 AM »
You should have had libgsm1-dev installed before installing yate. So, if you now have installed, you need to rebuild and reinstall Yate (so that Yate can detect that it has libgsm1-dev and can activate the support for it).
During reinstallation of Yate, during the configure step, make you see something like this in the output of configure:
Code: [Select]
checking for gsm.h in /usr/include... yes
Then reinstall Yate.
Afterwards, configure and reinstall YateBTS.
« Last Edit: May 21, 2015, 02:43:00 AM by oana »

andrew77

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Could not route call to '32843'
« Reply #13 on: May 21, 2015, 12:10:31 PM »
Ok,

in fact, unfortunately I installed yate and yatebts before installing libgsm1-dev...

but the wiki-yatebts doesn't explain it, the site lacks of information...:(

so now I overwrite yate and yatebts

thanks a lot
bye

Andrea