Author Topic: Registration failed on gsm network  (Read 9983 times)

nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Registration failed on gsm network
« on: May 13, 2015, 04:58:59 AM »
Hi,

00101 network has been detected by my phone, but registration always fail like this picture





what should i do for this problem?

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Re: Registration failed on gsm network
« Reply #1 on: May 13, 2015, 06:26:13 AM »
Hi,

please attach a log from YateBTS corresponding to this registration attempt.

You can find information about logging and debugging for YateBTS here:
http://wiki.yatebts.com/index.php/Logging_and_Debugging


nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Registration failed on gsm network
« Reply #2 on: May 13, 2015, 09:45:59 AM »
Hi,

please attach a log from YateBTS corresponding to this registration attempt.

You can find information about logging and debugging for YateBTS here:
http://wiki.yatebts.com/index.php/Logging_and_Debugging

sorry i'm not attach full log, a log is too large.

yes i have been followed that command , but i still can't register on test network

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Re: Registration failed on gsm network
« Reply #3 on: May 14, 2015, 01:34:47 AM »
It looks like you haven't configured your NIB to accept registrations from that IMSI.

You can allow registration from subscribers.conf or through the NIB web interface. You can also put a regexp to allow IMSIs that match that regexp to register (but please be careful not to accept everything, as it could possibly disrupt phones around).

Take a look at:
http://wiki.yatebts.com/index.php/Javascript_NIB#subscribers.conf
http://wiki.yatebts.com/index.php/Network_in_a_Box#Web_UI_for_NIB_Management

nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Registration failed on gsm network
« Reply #4 on: May 14, 2015, 05:41:53 AM »
It looks like you haven't configured your NIB to accept registrations from that IMSI.

You can allow registration from subscribers.conf or through the NIB web interface. You can also put a regexp to allow IMSIs that match that regexp to register (but please be careful not to accept everything, as it could possibly disrupt phones around).

i have configured NIB , BTS configuration , outgoing (SIP)
on subscriber : i'm try using regexp (^001 and .*) .  i can't input subcriber manual because i don't know to have Ki (card secret) , country code 410 (indonesia)


on BTS config : RadioBand (EGSM900), RadioCO (50: 945 downlink and 900 uplink)


I 'm doing a school assignment by using yatebts at locations not reachable by the BTS . at this location no one has phones (rural area)

what should i do now oana?

« Last Edit: May 14, 2015, 06:10:46 AM by nurwalid »

Monica Tepelus

  • Administrator
  • Full Member
  • *****
  • Posts: 198
    • View Profile
Re: Registration failed on gsm network
« Reply #5 on: May 14, 2015, 08:38:30 AM »
Hi,

What version of yatebts are you using? In older versions, nib script used subscribers.js file, not subscribers.conf

nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Registration failed on gsm network
« Reply #6 on: May 14, 2015, 07:51:50 PM »
Hi,

What version of yatebts are you using? In older versions, nib script used subscribers.js file, not subscribers.conf
Hi

I'm using new version of yatebts and yate from svn

So, nib acript used subscriber.conf?

Ioana Stanciu

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Re: Registration failed on gsm network
« Reply #7 on: May 15, 2015, 01:22:18 AM »
Yes, it should use subscribers.conf. And I dont know if it's a typo or not, but make sure the file is named subscribers.conf, not subscriber.conf.

First, the regexp  ^001 will never match your IMSI (log says that the IMSI of the phone trying to register starts with 510).
As for the regexp that would match everything ( .*) , make sure you're loading the configuration correctly.
You can check from where yate is loading subscribers.conf by typing status engine in the rmanager console and looking at the configpath variable. Check that you have subscribers.conf in that path, or  that the path corresponds to the folder where you've make all your configuration changes.


nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Registration failed on gsm network
« Reply #8 on: May 15, 2015, 11:19:25 AM »
Yes sure, i mean subscribers.conf not subscriber.conf

I will try it later.. If my radio board back here.

Thx oana, i will post my result with your solution soon.

nurwalid

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Registration failed on gsm network
« Reply #9 on: June 07, 2015, 11:26:44 PM »
hi oana..

i choose regexp .*
subscribers.conf availible on /usr/etc/local/yate/

and i still failed for register on network.

what should i do now?

thanks